Bug 182596 - Wrong hrStorageSize for NFS-mounted file system
Wrong hrStorageSize for NFS-mounted file system
Status: CLOSED DUPLICATE of bug 189238
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 11:03 EST by Carsten Clasohm
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 09:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Clasohm 2006-02-23 11:03:05 EST
Description of problem:

The hrStorageSize and hrStorageUsed values reported by snmpd are off by a factor
of 8 for NFS-mounted file systems.

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11.EL4.6

How reproducible: always

Steps to Reproduce:
1. Export a directory with NFS, and mount it on the same machine.
2. Configure and start snmpd.
3. Run "snmpwalk -Os -c public -v 1 localhost .1.3.6.1.2.1.25.2.3.1"
4. Compare hrStorageSize and hrStorageUsed for the directly mounted file system,
and for the NFS-mounted file system.
  
Actual results:

hrStorageDescr.4 = STRING: /
hrStorageDescr.11 = STRING: /mnt/net
hrStorageAllocationUnits.4 = INTEGER: 4096 Bytes
hrStorageAllocationUnits.11 = INTEGER: 4096 Bytes
hrStorageSize.4 = INTEGER: 18666796
hrStorageSize.11 = INTEGER: 2333350
hrStorageUsed.4 = INTEGER: 2696695
hrStorageUsed.11 = INTEGER: 337087

Expected results:

df -h
/dev/mapper/myvg-rootvol
                       72G   11G   58G  16% /
localhost:/            72G   11G   58G  16% /mnt/net
Comment 1 Radek Vokal 2006-02-24 04:25:52 EST
Yes, the allocation units for NFS should by 32kB. 
Comment 3 Bastien Nocera 2006-07-18 09:15:19 EDT
Duping now.

*** This bug has been marked as a duplicate of 189238 ***

Note You need to log in before you can comment on or make changes to this bug.