Bug 182601 - IDE zip drives
Summary: IDE zip drives
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-23 16:48 UTC by David Zeuthen
Modified: 2013-03-06 03:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 07:47:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from 'udevmonitor -e' after inserting Zip media and doing a 'blockdev --rereadpt /dev/hdd' (5.85 KB, text/plain)
2006-02-23 16:48 UTC, David Zeuthen
no flags Details
50-udev.rules (13.82 KB, text/plain)
2006-02-28 18:32 UTC, Harald Hoyer
no flags Details
output of udevmonitor -e == my udev database (3.08 KB, text/plain)
2006-02-28 19:33 UTC, David Zeuthen
no flags Details
50-udev.rules (13.60 KB, text/plain)
2006-03-01 08:33 UTC, Harald Hoyer
no flags Details
50-udev.rules (13.60 KB, text/plain)
2006-03-01 08:36 UTC, Harald Hoyer
no flags Details

Description David Zeuthen 2006-02-23 16:48:51 UTC
There are at least two problems in the way udev handles IDE zip drives

 1. We really need to create all the 15 child device nodes in advance.. HAL
relies on that.. E.g. I only see /dev/hdd, I really ought to see /dev/hdd1
through /dev/hdd15 as well even when no media is inserted

 2. There's a loop where udev spins when I insert media and do a blockdev
--rereadpt /dev/hdd - will attach the output

I'm using udev-084-4. I can test RPM's if you want (since IDE Zip drives are not
common place anymore I don't expect you to own one.)

I'm marking this as a FC5Blocker.

Comment 1 David Zeuthen 2006-02-23 16:48:51 UTC
Created attachment 125113 [details]
Output from 'udevmonitor -e' after inserting Zip media and doing a 'blockdev --rereadpt /dev/hdd'

Comment 2 David Zeuthen 2006-02-28 16:27:25 UTC
This problem is still present in udev-084-6! It is a regression from FC4.

Comment 3 Harald Hoyer 2006-02-28 18:32:59 UTC
Created attachment 125408 [details]
50-udev.rules

would that 50-udev.rules fix the problem??

Comment 4 David Zeuthen 2006-02-28 19:32:11 UTC
Fixes only half of the problem... I still don't get all_partitions.. but at
least udev now refuses to invoke volume_id on this disk..

BUS=="ide", KERNEL=="hd[a-z]", SYSFS{removable}=="1", \
        ENV{ID_MODEL}=="IOMEGA_ZIP*",   NAME="%k", OPTIONS+="all_partitions"

This is the problem I think.. The model name isn't mentioned in the database..
will attach contents of 'udevinfo -e'

Comment 5 David Zeuthen 2006-02-28 19:33:50 UTC
Created attachment 125410 [details]
output of udevmonitor -e == my udev database

Comment 6 David Zeuthen 2006-02-28 19:35:20 UTC
However..

# cat /proc/ide/hdd/model
IOMEGA ZIP 100 ATAPI

may udev needs to read ID_MODEL from /proc/ide/%k/model?

Comment 7 Harald Hoyer 2006-03-01 08:33:14 UTC
Created attachment 125448 [details]
50-udev.rules

next try

Comment 8 Harald Hoyer 2006-03-01 08:36:01 UTC
Created attachment 125449 [details]
50-udev.rules

typo in the last rules, try this one

Comment 9 David Zeuthen 2006-03-01 16:37:17 UTC
udev-084-8 works great for me, thanks!


Note You need to log in before you can comment on or make changes to this bug.