Bug 1826099 - u-boot does not load from sdcard on rockpro64
Summary: u-boot does not load from sdcard on rockpro64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uboot-tools
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-20 21:27 UTC by Dennis Gilmore
Modified: 2020-04-23 18:02 UTC (History)
9 users (show)

Fixed In Version: uboot-tools-2020.04-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-23 18:02:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Dennis Gilmore 2020-04-20 21:27:53 UTC
Description of problem:
u-boot fails to find u-boot.bin in the itb file when loading on the rockpro64


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. dd if=/usr/share/uboot/rockpro64-rk3399/idbloader.img of=/dev/sdf seek=64
2. dd if=/usr/share/uboot/rockpro64-rk3399/u-boot.itb of=/dev/sdf seek=16384
3. boot system from sdcard

Actual results:
U-Boot TPL 2020.04 (Apr 14 2020 - 00:00:00)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=16/15 CS=1 Die BW=16 Size=2048MB
256B stride
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2020.04 (Apr 14 2020 - 00:00:00 +0000)
Trying to boot from MMC1
fdt_find_or_add_subnode: fit-images: FDT_ERR_BADSTRUCTURE
fdt_find_or_add_subnode: fit-images: FDT_ERR_BADSTRUCTURE
fdt_find_or_add_subnode: fit-images: FDT_ERR_BADSTRUCTURE
fdt_find_or_add_subnode: chosen: FDT_ERR_BADSTRUCTURE
spl_perform_fixups: could not find/create '/chosen'

Expected results:
u-boot to be loaded and booting the system

Additional info:

Comment 1 Peter Robinson 2020-04-20 22:40:32 UTC
uboot-tools-2020.04-2.fc32 is building now with a fix.

Comment 2 Fedora Update System 2020-04-21 07:06:49 UTC
FEDORA-2020-e0ad98f651 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e0ad98f651

Comment 3 Fedora Blocker Bugs Application 2020-04-21 07:09:24 UTC
Proposed as a Freeze Exception for 32-final by Fedora user pbrobinson using the blocker tracking app because:

 Rockpro64 is a widely used device, fixes an issue booting from microSD card.

Comment 4 František Zatloukal 2020-04-21 16:25:56 UTC
+1 FE

Comment 5 Adam Williamson 2020-04-21 18:00:23 UTC
sure, +1 FE.

Comment 6 Fedora Update System 2020-04-21 18:43:27 UTC
FEDORA-2020-e0ad98f651 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e0ad98f651`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e0ad98f651

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Mohan Boddu 2020-04-21 18:59:44 UTC
Since we need to run another RC, +1 FE

Comment 8 Ben Cotton 2020-04-21 19:09:43 UTC
+1 FE, that seems like enough to accept. Marking as such.

Comment 9 Fedora Update System 2020-04-23 18:02:45 UTC
FEDORA-2020-e0ad98f651 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.