Bug 1826113 - LoadBalancerManaged status condition's "UnsupportedEndpointPublishingStrategy" reason is confusing
Summary: LoadBalancerManaged status condition's "UnsupportedEndpointPublishingStrategy...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Miciah Dashiel Butler Masters
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-20 22:24 UTC by Miciah Dashiel Butler Masters
Modified: 2020-07-13 17:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When an IngressController is configured to use an endpoint publishing strategy type other than "LoadBalancerService", the ingress operator does not manage a load balancer for that IngressController, and the operator accordingly sets the IngressController's "LoadBalancerManaged" status condition to "False" with an explanatory reason and message. However, the wording of the status condition's reason and message was unclear, in particular in its use of the word "unsupported". Consequence: The status condition confused users as to the reason why the operator was not managing a load balancer for the IngressController. Fix: The message has been updated to avoid using phrases such as "unsupported" or "does not support" when the endpoint publishing strategy does not include managing a load balancer. Result: The "LoadBalancerManaged" status condition should now be less confusing.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-ingress-operator pull 392 None closed Bug 1826113: status: Improve LoadBalancerManaged=false wording 2020-06-23 10:09:33 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:29:48 UTC

Description Miciah Dashiel Butler Masters 2020-04-20 22:24:40 UTC
Description of problem:

When an IngressController is configured to use an endpoint publishing strategy other than "LoadBalancerService", the ingress operator sets the "LoadBalancerManaged" status condition to "False", with the reason "UnsupportedEndpointPublishingStrategy" to indicate that the ingress operator does not manager a load balancer when the configured endpoint publishing strategy is used.  The "UnsupportedEndpointPublishingStrategy" reason is confusing to some users; the word "Unsupported" should be omitted.



Version-Release number of selected component (if applicable):

4.3



Steps to Reproduce:
1. Create an IngressController with spec.endpointPublishingStrategy.type set to a value other than "LoadBalancerService".
2. Look at the status of the IngressController created in Step 1.



Actual results:

The IngressController's status reports "UnsupportedEndpointPublishingStrategy":

      Message:               The endpoint publishing strategy does not support a load balancer
        Reason:                UnsupportedEndpointPublishingStrategy
        Status:                False
        Type:                  LoadBalancerManaged


Expected results:

The IngressController's status should report a less confusing reason, such as "EndpointPublishingStrategyExcludesManagedLoadBalancer".

Comment 4 Hongan Li 2020-05-06 07:57:53 UTC
Verified with 4.5.0-0.nightly-2020-05-04-113741 and the message has been updated as:

  - lastTransitionTime: "2020-05-06T07:51:47Z"
    message: The configured endpoint publishing strategy does not include a managed
      load balancer
    reason: EndpointPublishingStrategyExcludesManagedLoadBalancer
    status: "False"
    type: LoadBalancerManaged

Comment 5 errata-xmlrpc 2020-07-13 17:29:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.