Bug 1826126 - Operand form advanced fields within field/array field groups should render in the advanced configuration section
Summary: Operand form advanced fields within field/array field groups should render in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1831137
TreeView+ depends on / blocked
 
Reported: 2020-04-21 00:10 UTC by Jon Jackson
Modified: 2020-07-13 17:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On the create operand form, [array] field groups were taking priority over advanced fields. Consequence: If a field had both [array] field group and advanced descriptors, it would show up in the field group instead of the advanced fields section. Fix: Adjust grouping logic to prioritize advanced descriptor over [array] field group descriptor. Result: Fields with both [array] field group descriptor and advance descriptor now get grouped with advanced fields.
Clone Of:
: 1831137 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:29:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
AdvancedConfiguration (89.95 KB, image/png)
2020-05-08 03:37 UTC, Yanping Zhang
no flags Details
DeleteStrategy (78.21 KB, image/png)
2020-05-08 03:38 UTC, Yanping Zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:29:48 UTC

Description Jon Jackson 2020-04-21 00:10:24 UTC
Description of problem:
On the create operand form, advanced fields which are also within a field or array field group are currently rendered in their associated group instead of the 'Advanced Configuration' section.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Go to OperatorHub and install Portworx operator in a namespace
2. From the Portworx operator details page, create a Storage Cluster instance
3. Click 'Edit Form' in the top right
4. Scroll down until the 'Delete Strategy' field group is in view

Actual results:
The deleteStrategy dropdown is rendered in a field group titled 'Delete Strategy', near the top of the form.

Expected results:
The 'Delete Strategy' field group should not be rendered since it only contains one field which has an 'advanced' descriptor. The advanced descriptor should cause the Delete Strategy dropdown to be rendered in the 'Advanced Configuration' section at the bottom of the form instead.


Additional info:
This bug is created so that we can backport a fix to 4.4. This behavior is actually expected in 4.5

Comment 2 Jon Jackson 2020-05-04 17:26:36 UTC
Resolved by https://github.com/openshift/console/pull/4944

Comment 3 Yanping Zhang 2020-05-08 03:36:51 UTC
Checked on ocp 4.5 cluster with payload 4.5.0-0.nightly-2020-05-07-144853.
1. Go to OperatorHub and install Portworx operator in a namespace
2. From the Portworx operator details page, create a Storage Cluster instance
3. In the 'Edit Form' view, check the 'Delete Strategy' field group, it's still near the top of the form, not in the 'Advanced Configuration' section at the bottom of the form. Pls refer to screenshots.

Comment 4 Yanping Zhang 2020-05-08 03:37:53 UTC
Created attachment 1686371 [details]
AdvancedConfiguration

Comment 5 Yanping Zhang 2020-05-08 03:38:54 UTC
Created attachment 1686372 [details]
DeleteStrategy

Comment 6 Jon Jackson 2020-05-08 14:03:14 UTC
Sorry, Yanping I should have clarified this one a bit more. In 4.5 we moved to a different implementation around field groups and advanced descriptors. The behavior that was reported as a 4.4 bug here is very similar to what we intentionally implemented in 4.5. 

You'll notice that there is actually a separate 'Advanced Configuration' section in the 'Delete Strategy' field group now. This is the expected behavior and is slightly different than the bug being reported here.

Long story short, this bug has been fixed in 4.5 because there is a new behavior: Fields within a group that have an 'advanced' descriptor will be rendered in an 'Advanced Configuration' section within their parent field group instead of being moved into an Advanced Configuration section at the end of the entire form.

Comment 7 Yanping Zhang 2020-05-11 05:59:59 UTC
Thanks, Jon!.
According to Comment 3 and Comment 6, the bug is fixed, so move it to Verified.

Comment 9 errata-xmlrpc 2020-07-13 17:29:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.