Bug 182613 - Upgrade wipes out sectool wrappers
Upgrade wipes out sectool wrappers
Status: CLOSED UPSTREAM
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
1.0.2
:
Depends On:
Blocks: 183369
  Show dependency treegraph
 
Reported: 2006-02-23 12:45 EST by Rich Megginson
Modified: 2015-01-04 18:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 09:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
files for fix (248 bytes, text/plain)
2006-02-23 12:45 EST, Rich Megginson
no flags Details
diffs for fix (11.82 KB, text/plain)
2006-02-23 12:46 EST, Rich Megginson
no flags Details
diffs for fix (15.51 KB, text/plain)
2006-02-23 13:52 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2006-02-23 12:45:33 EST
We move the binaries (e.g. mv certutil certutil-bin) and create the shell script
wrappers during post install in ns-update.  However, when you do an upgrade
install, the new certutil is copied over the certutil shell script.
There are also a few other minor things we need to clean up for upgrade
installation.
1) upgradeServer doesn't recognize Red Hat or Fedora DS.
2) upgradeServer takes care of instance schema upgrades
3) admin server config files are different since FDS 1.0
4) No template for migrateTo4
Comment 1 Rich Megginson 2006-02-23 12:45:33 EST
Created attachment 125119 [details]
files for fix
Comment 2 Rich Megginson 2006-02-23 12:46:11 EST
Created attachment 125121 [details]
diffs for fix
Comment 3 Rich Megginson 2006-02-23 13:52:51 EST
Created attachment 125125 [details]
diffs for fix
Comment 4 Rich Megginson 2006-02-23 14:25:27 EST
Reviewed by: Pete and Nathan (Thanks!)
Files: https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=125119
Branch: HEAD
Fix Description: It's better if we just package those wrappers instead 
of creating them on the fly.  The new file sec_tools_wrappers is a 
simple shell script that assumes it's being run out of a parent/bin 
directory which contains a program called $0-bin, and the shared libs it 
needs are in parent/lib.  This shell script is copied to 
shared/bin/certutil, shared/bin/modutil, etc.  I had to create another 
makefile packaging macro to handle the case where you want to package a 
file under a different name than the original. Also
1) Add Red Hat and Fedora DS to upgradeServer
2) adminutil property directory is now adminutil-properties instead of 
property
3) General clean up of some upgrade install things
Platforms tested: Fedora Core 4
Flag Day: no
Doc impact: no
QA impact: should be covered by regular nightly and manual testing
New Tests integrated into TET: none

Note You need to log in before you can comment on or make changes to this bug.