Bug 1826286 - "reset all" doesn't work in blivet partitioning
Summary: "reset all" doesn't work in blivet partitioning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-04-21 11:26 UTC by Kamil Páral
Modified: 2020-04-23 18:02 UTC (History)
14 users (show)

Fixed In Version: anaconda-32.24.7-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-23 18:02:50 UTC
Type: Bug


Attachments (Terms of Use)
bug demonstration video (2.56 MB, application/x-matroska)
2020-04-21 11:27 UTC, Kamil Páral
no flags Details
anaconda.log (16.53 KB, text/plain)
2020-04-21 11:27 UTC, Kamil Páral
no flags Details
journal (617.28 KB, text/plain)
2020-04-21 11:28 UTC, Kamil Páral
no flags Details
lvm.log (171.79 KB, text/plain)
2020-04-21 11:28 UTC, Kamil Páral
no flags Details
program.log (1.77 KB, text/plain)
2020-04-21 11:28 UTC, Kamil Páral
no flags Details
storage.log (133.04 KB, text/plain)
2020-04-21 11:28 UTC, Kamil Páral
no flags Details
syslog (524.76 KB, text/plain)
2020-04-21 11:28 UTC, Kamil Páral
no flags Details
video - reset all, then undo, not original state (2.59 MB, application/x-matroska)
2020-04-21 12:22 UTC, Kamil Páral
no flags Details
An updates image with the fix (4.29 KB, application/gzip)
2020-04-21 12:42 UTC, Vendula Poncova
no flags Details

Description Kamil Páral 2020-04-21 11:26:02 UTC
Description of problem:
If I modify the disk in some way in anaconda's blivet partitioning and then want to reset the changes, pressing "reset all" button doesn't do anything. In custom partitioning, "reset all" works fine.

On F31 DVD, "reset all" worked fine even in blivet partitioning.

Version-Release number of selected component (if applicable):
Fedora-Server-dvd-x86_64-32-1.4.iso

How reproducible:
always

Steps to Reproduce:
1. prepare an existing installation (I used a default Server minimal installation, using LVM+xfs)
2. boot Anaconda, go to Blivet partitioning
3. delete all standard partitions, delete all LVs, delete all LVMs -> have the disk completely clean
4. press "reset all"
5. nothing happens

Actual results:
Disk state doesn't reset

Expected results:
Disk state resets to actual on-disk state

Comment 1 Kamil Páral 2020-04-21 11:27:12 UTC
Created attachment 1680522 [details]
bug demonstration video

See this video to see the bug occur.

Comment 2 Kamil Páral 2020-04-21 11:27:52 UTC
Created attachment 1680523 [details]
anaconda.log

Comment 3 Kamil Páral 2020-04-21 11:28:25 UTC
Created attachment 1680524 [details]
journal

Comment 4 Kamil Páral 2020-04-21 11:28:30 UTC
Created attachment 1680525 [details]
lvm.log

Comment 5 Kamil Páral 2020-04-21 11:28:34 UTC
Created attachment 1680526 [details]
program.log

Comment 6 Kamil Páral 2020-04-21 11:28:39 UTC
Created attachment 1680527 [details]
storage.log

Comment 7 Kamil Páral 2020-04-21 11:28:45 UTC
Created attachment 1680528 [details]
syslog

Comment 8 Kamil Páral 2020-04-21 11:29:57 UTC
I'm not sure if this is a blocker or "just" a commonbug, but it seems severe enough, proposing for discussion.

Comment 9 Kamil Páral 2020-04-21 11:41:42 UTC
It seems I can go back to the original state using "Undo last action" repeatedly. However, I'm not certain this will work for flawlessly for a high number of complex operations. Also, it only works as expected before you hit "Reset all". Even though it seemingly does nothing, I have found cases when subsequent "Undo last action" will then switch you to a different state than the one you arrived from. To sum up, as long as "Reset all" is broken, I'd consider any use of it to switch the system into an undefined state.

Comment 10 Kamil Páral 2020-04-21 12:22:22 UTC
Created attachment 1680535 [details]
video - reset all, then undo, not original state

Here's an example of how "Reset all" and then "Undo last action" doesn't go back to the original state - the first partition used to be sda1, but then it is sda2. So it is not suitable as a workaround.

Comment 11 Vendula Poncova 2020-04-21 12:40:27 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/2458

Comment 12 Vendula Poncova 2020-04-21 12:42:07 UTC
Created attachment 1680539 [details]
An updates image with the fix

Comment 13 Ben Cotton 2020-04-21 13:11:57 UTC
+1 blocker I think this is a visible enough problem early in the experience that it's worth blocking on, although I won't object if the consensus is that it's not a blocker because there's a workaround that can be documented in CommonBugs.

Comment 14 Kamil Páral 2020-04-21 13:12:46 UTC
(In reply to Vendula Poncova from comment #12)
> Created attachment 1680539 [details]
> An updates image with the fix

Fixes the problem, thanks.

Comment 15 Mohan Boddu 2020-04-21 14:02:50 UTC
Seems like a +1 Blocker to me.

Comment 16 Stephen Gallagher 2020-04-21 14:13:14 UTC
@Kamil: Was this broken in F31 as well? If so, I'll offer this fix a +1 FE, but if it worked then and has regressed in F32, I'll agree to call it a blocker.

Comment 17 Mohan Boddu 2020-04-21 15:02:37 UTC
From comment0

> On F31 DVD, "reset all" worked fine even in blivet partitioning.

It worked in F31, which is why I went with +1 Blocker.

Comment 18 sumantro 2020-04-21 15:17:32 UTC
+1 blocker

Comment 19 František Zatloukal 2020-04-21 15:41:00 UTC
+1 Blocker

Comment 20 Adam Williamson 2020-04-21 15:48:05 UTC
+1 blocker, also I once again cash in my "we really shouldn't have two separate custom partitioning UIs" card!

Comment 21 Adam Williamson 2020-04-21 17:23:18 UTC
That's enough votes to accept this.

Comment 22 Fedora Update System 2020-04-21 18:36:05 UTC
FEDORA-2020-efbff266dc has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-efbff266dc

Comment 23 Kamil Páral 2020-04-22 08:42:21 UTC
(In reply to Fedora Update System from comment #22)
> FEDORA-2020-efbff266dc has been submitted as an update to Fedora 32.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-efbff266dc

Verified fixed with RC 1.5.

Comment 24 Fedora Update System 2020-04-23 17:42:02 UTC
FEDORA-2020-efbff266dc has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-efbff266dc

Comment 25 Fedora Update System 2020-04-23 17:55:15 UTC
FEDORA-2020-efbff266dc has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-efbff266dc

Comment 26 Fedora Update System 2020-04-23 18:02:50 UTC
FEDORA-2020-efbff266dc has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.