Bug 182648 - netdump wont load kernel modules on HP XW9300
netdump wont load kernel modules on HP XW9300
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: netdump (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Graf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 15:56 EST by Tobias Schaefer
Modified: 2014-06-18 04:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 18:01:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport (no rpm data) (451.26 KB, application/x-bzip2)
2006-02-23 15:56 EST, Tobias Schaefer
no flags Details
sysreport (nvnet driver) (471.72 KB, application/x-bzip2)
2006-02-23 17:42 EST, Tobias Schaefer
no flags Details

  None (edit)
Description Tobias Schaefer 2006-02-23 15:56:36 EST
Description of problem:
netdump kernel modules ("netdump","netconsole") won't load on HP XW9300


Version-Release number of selected component (if applicable): netdump-0.7.7-3


How reproducible: Always on HP XW9300 (RHEL4U2 ES AMD64 SMP)
Works always on other x86_64 systems (E.g. HP XW8200, Fujitsu-Siemens Celsius
V830, IBM Intellistation A Pro 6217,...)


Steps to Reproduce:
1. service netdump start
2. provide netdump password at the prompt
3.
  
Actual results:

[root@hp-amd-1 ~]# service netdump start
netdump@10.0.13.3's password:
initializing netdump FATAL: Error inserting netdump
(/lib/modules/2.6.9-22.ELsmp/kernel/drivers/net/netdump.ko): Invalid argument
                                                           [FAILED]
initializing netconsole FATAL: Error inserting netconsole
(/lib/modules/2.6.9-22.ELsmp/kernel/drivers/net/netconsole.ko): Invalid argument
                                                           [FAILED]
[root@hp-amd-1 ~]#  


Expected results:

[root@hp-intel-1 ~]# service netdump start
netdump@10.0.13.3's password:
initializing netdump                                       [  OK  ]
initializing netconsole                                    [  OK  ]
[root@hp-intel-1 ~]# 



Additional info: sysreport in attachment
Comment 1 Tobias Schaefer 2006-02-23 15:56:36 EST
Created attachment 125135 [details]
sysreport (no rpm data)
Comment 2 Dave Anderson 2006-02-23 16:29:30 EST
Strange -- looking at your /var/log/messages file:

  netdump: eth0 doesn't support polling, aborting.
  netconsole: eth0 doesn't support polling, aborting.
  netlog: eth0 doesn't support polling, aborting.

netdump and netconsole (and netlog via netconsole) all utilize the
in-kernel netpoll facility, and the netpoll facility is failing 
because the eth0 NIC driver does not support polling mode, i.e.,
never set up its poll_controller() interface:

int netpoll_setup(struct netpoll *np)
{
        struct net_device *ndev = NULL;
        struct in_device *in_dev;

        if (np->dev_name)
                ndev = dev_get_by_name(np->dev_name);
        if (!ndev) {
                printk(KERN_ERR "%s: %s doesn't exist, aborting.\n",
                       np->name, np->dev_name);
                return -1;
        }
        if (!ndev->poll_controller) {
                printk(KERN_ERR "%s: %s doesn't support polling, aborting.\n",
                       np->name, np->dev_name);
                goto release;
        }
        ...

It appears your eth0 driver is forcedeth.c, right?  And if configured properly,
it does have a poll_controller interface -- in forcedeth.c:nv_probe() there's
this:

#ifdef CONFIG_NET_POLL_CONTROLLER
        dev->poll_controller = nv_poll_controller;
#endif

and CONFIG_NET_POLL_CONTROLLER is turned on by default in RHEL4 kernels.

Are you rebuilding kernels, or drivers, or doing anything out of the ordinary?





Comment 3 Tobias Schaefer 2006-02-23 17:42:01 EST
Created attachment 125145 [details]
sysreport (nvnet driver)
Comment 4 Tobias Schaefer 2006-02-23 17:48:44 EST
there is one thing: I'm booting into the PXE first. Then I chose a hard disk
boot in the PXE. (The system is installed frequently via PXE.) The behavior
doesnt change if I boot directly from hard disk. (Again using the forcedeth driver.)

With your hint pointing to the ethernet driver I tested the same on a SUN Ultra
40 Workstation. (Similar configuration, forcedeth driver.) This system shows the
same error.

Back to the XW9300 I configured NVIDIAs nvnet driver. This shows the same
failure on the command line. But I have attached another sysreport from this
configuration.
Comment 5 Dave Anderson 2006-02-24 08:48:29 EST
Tom, Jeff,

I have no idea what's going on here -- for whatever reason the
dev->poll_controller is not being initialized?  Is there something
special about the forcedeth driver that doesn't support netpoll?

Dave
Comment 6 Jeffrey Moyer 2006-02-24 09:47:43 EST
The forcedeth driver in 2.6.9-22 does not support netpoll.  Netpoll support was
added in kernel 2.6.9-22.16, and should be available in the next update.  Having
said that, I don't have any forcedeth hardware to use for testing.
Comment 7 Dave Anderson 2006-02-24 09:57:59 EST
> #ifdef CONFIG_NET_POLL_CONTROLLER
>         dev->poll_controller = nv_poll_controller;
> #endif
> 
> and CONFIG_NET_POLL_CONTROLLER is turned on by default in RHEL4 kernels.
>
> Are you rebuilding kernels, or drivers, or doing anything out of the ordinary?

Sorry about that -- I was looking at a 2.6.9-24 source tree...

Comment 8 Lonni J Friedman 2006-03-07 11:23:30 EST
In my testing the latest kernel from here resolves this bug :
http://people.redhat.com/linville/kernels/rhel4
Comment 9 Tobias Schaefer 2006-03-09 18:01:14 EST
I can confirm that the kernel from kernel-smp-2.6.9-34.EL.jwltest.119.x86_64.rpm
resolves the problem on both systems. (Sun Ultra 40 and HP XW9300 using
forcedeth version 0.52 as driver.)

Note You need to log in before you can comment on or make changes to this bug.