Bug 1826510 - Fix 'clear all filters' isn't consistently displaying on the filter toolbar (serach page only)
Summary: Fix 'clear all filters' isn't consistently displaying on the filter toolbar (...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-21 20:22 UTC by Joe Caiani
Modified: 2020-07-13 17:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: clear all filters had a bug in the upstream pf component Consequence: clear all filters worked incorrectly in the search page Fix: made upstream fix for clear all filters in toolbar filter component Result: clear all filters successfully clears all filters now
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5138 0 None closed Bug 1826510: Fix clear all issue in both pf and in product 2020-06-23 10:14:27 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:15 UTC

Description Joe Caiani 2020-04-21 20:22:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Yanping Zhang 2020-04-23 05:16:30 UTC
There is no 'clear all filters' for filter on Events page, should it be added, too?

Comment 4 Yanping Zhang 2020-04-26 02:08:50 UTC
To keep consistent with other page, it's better to have "clear all filters" on event page, so assign back the bug.

Comment 5 Joe Caiani 2020-04-26 21:15:07 UTC
(In reply to Yanping Zhang from comment #4)
> To keep consistent with other page, it's better to have "clear all filters"
> on event page, so assign back the bug.

Hi yanping, this bug was only for the pf toolbar component which is only in the search page as of now. The toolbar component story will be expanded in 4.6. For now, this is just for search toolbar. Thanks!

Comment 6 Yanping Zhang 2020-04-27 01:41:21 UTC
Joe, thanks for your info. 
Now the "clear all filters" works on search page on 4.5 cluster with payload 4.5.0-0.nightly-2020-04-25-170442, so move the bug to Verified.

Comment 7 errata-xmlrpc 2020-07-13 17:29:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.