Bug 1826526 - In Start Pipeline Modal, if no resources exist, show Create Resource in dropdown
Summary: In Start Pipeline Modal, if no resources exist, show Create Resource in dropdown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-21 21:27 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Internal issue prevented a good experience when there were no Pipeline Resources created in the namespace and the Start Pipeline modal needed one. Consequence: The user would see a disabled and empty dropdown above fields, losing some context of what the fields were for. Fix: Fix the internal issue and show "Create Pipeline Resource" to give the user context of what they were doing inline in the Start Pipeline modal. Result: The user has a better experience starting a Pipeline from the start modal when there are no Pipeline Resources created in the namespace.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
In Start Pipeline Modal, if no resources exist, show Create Resource in dropdown (26.24 KB, image/png)
2020-05-19 20:25 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5140 None closed Bug 1826526: Improves Start Pipeline Resource section 2020-07-09 14:54:26 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:30:15 UTC

Description Andrew Ballantyne 2020-04-21 21:27:56 UTC
Description of problem:
Some visual issues are with the Start Pipeline modal's Resource dropdowns:

1) Needs text in the dropdown
2) Needs to change from "Create New Pipeline Resource" to "Create Pipeline Resource"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Have a Pipeline with Resources (but don't have any in your namespace)
2. Use the "Start Pipeline" action

Actual results:
Empty Pipeline resource dropdown while it's disabled

Expected results:
"Create Pipeline Resource" to be in the dropdown while it's disabled

Additional info:

Comment 4 spathak@redhat.com 2020-05-19 20:25:11 UTC
Created attachment 1689978 [details]
In Start Pipeline Modal, if no resources exist, show Create Resource in dropdown

Comment 5 spathak@redhat.com 2020-05-20 05:50:47 UTC
Verified on build version: 4.5.0-0.ci-2020-05-18-204038
Browser version: Firefox73

Comment 6 errata-xmlrpc 2020-07-13 17:29:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.