Bug 1826628 - Custom route not deleted after it is unset from console operator config
Summary: Custom route not deleted after it is unset from console operator config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1826689 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 07:39 UTC by Jakub Hadvig
Modified: 2020-07-13 17:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Console operator is not checking for removing of the custom route from the console operator config. Consequence: After the hostname for the console's custom route is unset from console operator config, the custom route is still available Fix: Console operator checks for the presence of the custom route in its config. Result: Custom route is removed after its unset in the console operator's config
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 418 0 None closed Bug 1826628: Delete custom route after it is unset from console operator config 2020-06-23 10:14:45 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:15 UTC

Description Jakub Hadvig 2020-04-22 07:39:15 UTC
Description of problem:
After the hostname for the console's custom route is unset from console operator config, the custom route is still available

Version-Release number of selected component (if applicable):
4.5.0-0.ci-2020-04-21-234936

How reproducible:
Always


Steps to Reproduce:
1. Set the spec of the console operator config with the custom hostname
```
spec:
  managementState: Managed
  route:
    hostname: consolecustom-openshift-console.apps.<cluster-domain>
```
2. Wait for the custom route to be created
3. Remove the `route` field from the console operator config spec

Actual results:
The custom route for the console is still available.

Expected results:
The custom route for the console should be removed.

Additional info:

Comment 3 shahan 2020-04-23 03:58:17 UTC
1. Set the spec of the console operator config with the custom hostname
```
spec:
  managementState: Managed
  route:
    hostname: consolecustom-openshift-console.apps.<cluster-domain>
```
2. Wait for the custom route to be created
3. Remove the `route` field from the console operator config spec
 The custom console route has been deleted
4.5.0-0.ci-2020-04-22-212726

Comment 4 Jakub Hadvig 2020-04-23 07:09:36 UTC
*** Bug 1826689 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-07-13 17:29:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.