Bug 1826630 - create a silence then edit the silence, during value is not populated
Summary: create a silence then edit the silence, during value is not populated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 07:49 UTC by hongyan li
Modified: 2020-07-13 17:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5209 0 None closed Bug 1826630: Monitoring: Fixes for silence form duration handling 2020-06-23 10:15:17 UTC
Github openshift console pull 5239 0 None closed Bug 1826630: Monitoring: On editing silence in the past, default start time to now 2020-06-23 10:15:17 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:15 UTC

Description hongyan li 2020-04-22 07:49:39 UTC
Description of problem:
create a silence then edit the silence, during value is not populated

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-21-103613

How reproducible:
always

Steps to Reproduce:
1.Go to Monitoring-Alerts, click combo icon to selience an alert
2.set during value, such as 1d, click silence button
3.click Actions - edit silence

Actual results:
during value input has no value, it shows "-" on UI

Expected results:
during value input should have value we set, even the create silence page has a default value 2h

Additional info:

Comment 5 hongyan li 2020-04-30 03:06:07 UTC
test with payload 4.5.0-0.nightly-2020-04-29-215453
now create a silence, edit the silence check the during value can be populated, but when edit the silence the during value will be gone

Comment 9 hongyan li 2020-05-06 01:27:22 UTC
Test with payload 4.5.0-0.nightly-2020-05-04-113741
When edit silence, start time is now and end time is as set before, so duration has no value.

Comment 10 errata-xmlrpc 2020-07-13 17:29:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.