Bug 1826646 - shows alert in eventsources form if knative service is not present in namespace
Summary: shows alert in eventsources form if knative service is not present in namespace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 08:43 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Alert of not having kn service (127.30 KB, image/png)
2020-04-29 08:43 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5144 0 None closed Bug 1826646: shows alert in eventsources form if knative service is not present in namespace 2020-06-23 10:15:18 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:15 UTC

Description Jaivardhan Kumar 2020-04-22 08:43:24 UTC
Description of problem:
In Console EventSources form supports only sink to knative Service and in case of no associated service for that form will be never get enabled and user has not much information apart from form field

Version-Release number of selected component (if applicable): 4.5


How reproducible: Always


Steps to Reproduce:
1. Install Serverless operator and eventing operator
2. create a namespace 
3. go to DevConsole -> Add -> EventSources

Actual results:No alert is shown to user in case of knative service is not there


Expected results: Alert should be shown to user in case of knative service is not there


Additional info:

Comment 3 Gajanan More 2020-04-29 08:42:06 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-04-29-040854
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot
Marking this as verified

Comment 4 Gajanan More 2020-04-29 08:43:20 UTC
Created attachment 1682777 [details]
Alert of not having kn service

Comment 5 errata-xmlrpc 2020-07-13 17:29:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.