Bug 1826680 - non-existed service should display None same as the other empty fields on operator instance page
Summary: non-existed service should display None same as the other empty fields on ope...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1827766
TreeView+ depends on / blocked
 
Reported: 2020-04-22 10:17 UTC by XiaochuanWang
Modified: 2020-07-13 17:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1827766 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:30:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot for the issue (162.13 KB, image/png)
2020-04-22 10:17 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5153 None closed Bug 1826680: Fix bug where K8sResourceLink lacks empty state 2020-06-22 03:37:59 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:30:22 UTC

Description XiaochuanWang 2020-04-22 10:17:57 UTC
Created attachment 1680800 [details]
screenshot for the issue

Description of problem:
After user installed an operator and created instance, if there is no Service created, the field should display None just as the other empty fields

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-21-103613

How reproducible:
Always

Steps to Reproduce:
1.User installed an operator such as Etcd, and created instance such as EtcdCluster
2.Check the detail page of EtcdCluster.
url: k8s/ns/prozyp/clusterserviceversions/etcdoperator.v0.9.4/etcd.database.coreos.com~v1beta2~EtcdCluster/example/


Actual results:
2. The Service field has an icon and display empty as service name

Expected results:
2. Service field should display None which is same as the other empty fields.

Additional info:

Comment 3 XiaochuanWang 2020-04-27 03:01:07 UTC
Now the Service empty value displays "None" as expected.
Verified on 4.5.0-0.nightly-2020-04-26-203839

Comment 4 errata-xmlrpc 2020-07-13 17:30:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.