Bug 1826682 - Cannot validate bitbucket repository
Summary: Cannot validate bitbucket repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 10:23 UTC by Vikram Raj
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
bitbucket repo is validated (132.46 KB, image/png)
2020-04-27 11:07 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5146 0 None closed Bug 1826682: fix validation issue with bitbucket repository 2021-02-10 09:31:13 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:22 UTC

Description Vikram Raj 2020-04-22 10:23:58 UTC
Description of problem:
on Git url validation it shows repository not reachable even though it actually exists

Note: This appears to be a case-sensitive check problem.

have attached screenshots for the same

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to import from git page.
2. Enter the Bitbucket repository URL in Git repo URL field(Repository name should be in camelCase and public). 
3. On blur, you will see the error message "Git repository is not reachable."

Actual results:
Getting "Git repository is not reachable" error message even if repository exits and public URL.

Expected results:
The repository should get validated without an error message "Git repository is not reachable"

Comment 3 Gajanan More 2020-04-27 11:07:39 UTC
Created attachment 1682128 [details]
bitbucket repo is validated

Comment 4 Gajanan More 2020-04-27 11:08:11 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-04-26-162607
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:30:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.