Bug 182674 - Latest udev gives lots of error messages and breaks KDE automounting
Latest udev gives lots of error messages and breaks KDE automounting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: Regression
: 182723 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 17:32 EST by Fabio Comolli
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 08:08:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabio Comolli 2006-02-23 17:32:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
After today upgrade, starting udev floods the console with lots of error messages like this:

Feb 23 12:11:58 kepler udevd-event[2683]: wait_for_sysfs: waiting for '/sys/class/drm/card0/bus' failed
Feb 23 12:11:58 kepler udevd-event[2684]: wait_for_sysfs: waiting for '/sys/class/drm/card1/bus' failed

The other messages are lost because syslog was not yet running. There was a message for nearly every driver.

After login, plugging an external USB drive generates these errors:

Feb 23 12:23:00 kepler udevd-event[3173]: wait_for_sysfs: waiting for '/sys/class/scsi_generic/sg2/bus' failed
Feb 23 12:23:00 kepler udevd-event[3171]: wait_for_sysfs: waiting for '/sys/block/sdb/bus' failed
Feb 23 12:23:00 kepler udevd-event[3172]: wait_for_sysfs: waiting for '/sys/class/scsi_device/2:0:0:0/bus' failed
Feb 23 12:23:03 kepler udevd-event[3192]: wait_for_sysfs: waiting for '/sys/block/sdb/sdb1/bus' failed
Feb 23 12:23:03 kepler udevd-event[3193]: wait_for_sysfs: waiting for '/sys/block/sdb/sdb2/bus' failed

After that, KDE does not automount the filesystems on that drive.

Version-Release number of selected component (if applicable):
udev-084-4

How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.
  

Additional info:

Reverting udev to the previous version udev-084-1.1 fixes that.
Comment 1 Harald Hoyer 2006-02-24 11:03:10 EST
*** Bug 182723 has been marked as a duplicate of this bug. ***
Comment 2 Remi Collet 2006-02-25 04:23:58 EST
New udev-084-6 also fixes that.
Comment 3 Fabio Comolli 2006-02-25 06:05:08 EST
Confirmed. Everything is OK with today's rawhide (2006025).
Comment 4 Andreas Bierfert 2006-02-26 03:39:43 EST
Same here :) Finally...

Note You need to log in before you can comment on or make changes to this bug.