Bug 1826768 - Topology layout with force setting does not keep nodes separated
Summary: Topology layout with force setting does not keep nodes separated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 14:03 UTC by Jeff Phillips
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-04-17-081422 Cluster ID: 3bfb527c-a927-4ead-bc8e-c39ac70243f9 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.113 Safari/537.36
Last Closed: 2020-07-13 17:30:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Nodes goes away from each other in layout 2 (749.67 KB, video/mp4)
2020-04-27 05:24 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5149 0 None closed Bug 1826768: Fix for topology layout 2 layout keeping nodes separated 2020-06-23 10:15:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:39 UTC

Description Jeff Phillips 2020-04-22 14:03:30 UTC
Description of problem:

When using Layout 2 in the topology view, the layout should keep nodes separated when being dragged. The nodes are not keeping separated until the drag is ended, then the separation occurs.


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

1. In the topology view, drag a node near other nodes

Actual results:

the non-dragged node is not moved to separate from the dragged node
when the drag is ended, nodes get separated

Expected results:

non-dragged nodes should move away from the node being dragged during the drag operation


Additional info:

Comment 3 Gajanan More 2020-04-27 05:24:50 UTC
Created attachment 1682012 [details]
Nodes goes away from each other in layout 2

Comment 4 Gajanan More 2020-04-27 05:25:16 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-04-26-162607
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.
Please have a look at the recorded video.

Comment 5 errata-xmlrpc 2020-07-13 17:30:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.