This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 182679 - Beagle trigger incorrect on ppc64
Beagle trigger incorrect on ppc64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 182569 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-23 17:52 EST by Paul Nasrat
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 10:29:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2006-02-23 17:52:52 EST
Description of problem:

Updating: beagle
/var/tmp/rpm/rpm-tpm.97919: line 8: cd: /usr/lib64/firefox-1.5.0.1/extensions:
No such file or directory

Version-Release number of selected component (if applicable):

beagle-0.2.1-11

How reproducible:

Always
Steps to Reproduce:
1. Install beagle (assuming firefox installed) on a ppc64 box
  
Actual results:

Trigger fails

Expected results:

Trigger works

Additional info:

You can not assume the presence of lib64 indicates that that is the primary
arch, this is untrue on big-endian 64bit systems (ppc64, sparc64) which run the
32 bit arch as the primary arch.  The trigger is completely incorrect for these
archs
Comment 1 Matthias Clasen 2006-02-23 23:10:35 EST
Hmm, I could do 

if [ -d /usr/lib64/firefox-$latest/extensions ]; then
  libdir=/usr/lib64
else
  libdir=/usr/lib
fi

Or can I use %{_libdir} in a trigger ?  That would be nicer.
Comment 2 Matthias Clasen 2006-02-24 00:22:58 EST
*** Bug 182569 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Clasen 2006-02-24 01:48:05 EST
I tried to make the trigger more robust, can you try again, Paul ?
Comment 4 Matthias Clasen 2006-03-01 09:55:23 EST
Paul, any luck ?

Warren, did you want to take a stab at improving the trigger ?
Comment 5 Paul Nasrat 2006-03-01 10:29:26 EST
Yes the trigger no longer fails on the G5.
Comment 6 Warren Togami 2006-03-01 16:27:17 EST
I still want to rewrite the entire %post and %trigger because this leaves behind
files and is untracked by RPM.  This is a clean way of doing this.
Comment 7 Warren Togami 2006-03-01 16:27:47 EST
Er, I mean there is a clean way of doing this.

Note You need to log in before you can comment on or make changes to this bug.