Bug 182682 - severe rendering problems when run with Xair
severe rendering problems when run with Xair
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Carl Worth
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-02-23 18:03 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-16 19:11:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-02-23 18:03:04 EST
Description of problem:
If I switch from Xorg to Xair, attempts to run rdesktop hit major rendering
problems.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xair-1.0.0.0.20060207-5
rdesktop-1.4.1-3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Switch from Xorg to Xair
2. Fire up rdesktop
  
Actual results:
Instead of a login window, I see a blank window with a background color and a
few line segments (bevels?).

Expected results:
The login window presented by the server.

Additional info:
If I turn on the Composite extension under Xorg, it continues to work.
Attempts to capture an image of the rendering corruption fail, suggesting that
it's an error displaying the image rather than garbled image data.
Comment 1 Nalin Dahyabhai 2006-03-16 19:11:49 EST
It looks like this is fixed in xorg-x11-server-Xorg-1.0.1-8, which I'm told
incorporates the changes which were made in Xair, so I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.