Bug 182690 - gnome-mount does not remove floppy mountpoints
gnome-mount does not remove floppy mountpoints
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 21:03 EST by Michal Jaegermann
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 14:42:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-02-23 21:03:10 EST
Description of problem:

After floppy was mounted, with a help of a floppy icon in a "Computer"
window, unmounting it via 'gnome-mount' leaves its mount point in /media.
In a result repeting this operation quickly fills /media with
/media/floppy, /media/floppy-1, /media/floppy-2, ...

To add insult to injury even when a non-root user was mounting that floppy
all these mountpoints are owned by 'root' so they cannot be cleaned up.

Version-Release number of selected component (if applicable):
gnome-mount-0.4-0.cvs20060213.1

How reproducible:
always
Comment 1 David Zeuthen 2006-02-24 19:22:40 EST
Right, HAL should refuse to mount /dev/fd0 multiple times. Reassigning.
Comment 2 Michal Jaegermann 2006-02-24 20:46:32 EST
I think that this is a misunderstanding.  /dev/fd0 is _not_ mounted multiple
times.  It is mounted, unmounted, mounted, unmounted, .... but every such
cycle via desktop (hence presumably through gnome-mount) leaves behind
an _unused_ mount point and the next cycle is not reusing it but creates
a new one; presumably under an assumption that that an old mountpoint will
vanish.  Why those which are unused cannot be "recycled" is a good question.
An implementation lacking in robustness, I guess.

If you are root then you can do 'rm -rf /media/floppy*' and start again
from scratch.  If you are not root then you are stuck.
Comment 3 Michal Jaegermann 2006-02-24 20:59:23 EST
BTW - I noticed now that while 'gnome-mount -e -d /dev/fd0' leaves a stale
mountpoint behind this does not happen if 'gnome-umount -d /dev/fd0' is used
instead.  It looks that an icon menu, when it happens to work at all,
is using the first form, or an equivalent, and not the second one.

Also one would expect, looking at '--help', that all forms:

   gnome-mount -e -d /dev/fd0
   gnome-umount -d /dev/fd0
   gnome-umount -e -d /dev/fd0

will be equivalent.  They are not and the third one is silently doing nothing.
Comment 4 Michal Jaegermann 2006-03-01 14:42:02 EST
The original problem seems to be gone.  I guess I will close that one and
for issues mentioned in comment #3 will open another report.

Note You need to log in before you can comment on or make changes to this bug.