Bug 1826913 - Toggling On/Off for Knative Event Sources or Virtual Machines is Jarring
Summary: Toggling On/Off for Knative Event Sources or Virtual Machines is Jarring
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 18:28 UTC by Jeff Phillips
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.nightly-2020-03-17-181056 Cluster ID: 6a4138c1-5915-4562-9f5d-aec918eb92a7 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.113 Safari/537.36
Last Closed: 2020-07-13 17:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5154 0 None closed Bug 1826913: Fix topology to prevent initial drawing of new nodes at upper left 2020-06-23 10:16:39 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:43 UTC

Description Jeff Phillips 2020-04-22 18:28:54 UTC
Description of problem:

When the Event Sources or Virtual Machines display toggle is turn from off to on, the node(s) for the resource(s) are drawn in the top left corner then moved quickly to the calculated locations. This is quite jarring for the user.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. navigate to the topology view with either Event Sources or Virtual Machines
2. toggle the display off for the resources.
3. Navigate away from topology
4. Navigate back to topology
5. Toggle the display back on again.

Actual results:

Nodes are drawn in the upper left then quickly drawn again in calculated locations

Expected results:

Nodes are drawn close to the final locations and moved to the calculated locations to be less jarring on the user.

Additional info:

Comment 3 Gajanan More 2020-05-06 06:26:12 UTC
I have validated the bugzilla on:
Build:4.5.0-0.ci-2020-05-05-224426
Browser:Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.