Bug 1826925 - gpgv2: symbol lookup error: /lib64/libgcrypt.so.20: undefined symbol: dlopen
Summary: gpgv2: symbol lookup error: /lib64/libgcrypt.so.20: undefined symbol: dlopen
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgcrypt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1820902
TreeView+ depends on / blocked
 
Reported: 2020-04-22 19:05 UTC by Richard W.M. Jones
Modified: 2020-04-23 11:58 UTC (History)
5 users (show)

Fixed In Version: libgcrypt-1.8.5-6.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-23 11:58:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2020-04-22 19:05:58 UTC
Description of problem:

At the moment we cannot run gpgv2 in Rawhide.  It fails with
this weird error which I guess is something to do with gcrypt:

+ /usr/lib/rpm/redhat/gpgverify --keyring=/builddir/build/SOURCES/libguestfs.keyring --signature=/builddir/build/SOURCES/libguestfs-1.42.0.tar.gz.sig --data=/builddir/build/SOURCES/libguestfs-1.42.0.tar.gz
gpgv2: symbol lookup error: /lib64/libgcrypt.so.20: undefined symbol: dlopen
gpgverify: Signature verification failed.

Version-Release number of selected component (if applicable):

libgcrypt 1.8.5-5.fc33
gnupg2 2.2.20-1.fc33

How reproducible:

?

Steps to Reproduce:
1. Try gpgverify or gpgv2 commands.

Comment 2 Richard W.M. Jones 2020-04-23 08:25:39 UTC
Looks like there's a fix going into Koji:

https://koji.fedoraproject.org/koji/buildinfo?buildID=1497377

Comment 3 Tomas Mraz 2020-04-23 09:04:25 UTC
yes, unfortunately there is problem with libkcapi-fipscheck that breaks the build. I need to fix that one first.

Comment 4 Miro Hrončok 2020-04-23 10:13:49 UTC
Consider untagging the bad build in the meantime.


Note You need to log in before you can comment on or make changes to this bug.