Bug 1826933 - Helm releases should show the chart icon instead of helm icon
Summary: Helm releases should show the chart icon instead of helm icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 19:23 UTC by Rohit Rai
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Chart icon (169.74 KB, image/png)
2020-05-08 07:08 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5155 0 None closed Bug 1826933: Show helm chart icon in group label in topology 2020-07-03 10:05:10 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:43 UTC

Description Rohit Rai 2020-04-22 19:23:29 UTC
Description of problem: Helm releases have chart icons that are not being shown  on topology in helm groups. The default helm icon is shown always.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a Helm chart from catalog or CLI.
2. Go to Topology.


Actual results:
All helm release groups show default helm icons.

Expected results:
The helm releases with a chart icon URL available should show that icon instead of default helm icon.

Additional info:

Comment 3 Gajanan More 2020-05-08 07:08:19 UTC
Created attachment 1686382 [details]
Chart icon

Comment 4 Gajanan More 2020-05-08 07:09:22 UTC
I have validated the bugzilla on
Build: 4.5.0-0.ci-2020-05-06-053625
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot
Marking this as a verified.

Comment 5 errata-xmlrpc 2020-07-13 17:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.