Bug 1826937 - Subscription details channel button text can overflow cell
Summary: Subscription details channel button text can overflow cell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 19:47 UTC by Robb Hamilton
Modified: 2020-07-13 17:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-04-22-091616 Cluster ID: c377171a-8172-49e8-ae39-c91e322bd91d Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.113 Safari/537.36
Last Closed: 2020-07-13 17:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Channel name overflows (114.32 KB, image/png)
2020-04-22 19:47 UTC, Robb Hamilton
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5158 0 None closed Bug 1826937: Fix bug where subscription channel name can overflow box 2020-07-23 09:59:51 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:43 UTC

Description Robb Hamilton 2020-04-22 19:47:20 UTC
Created attachment 1680974 [details]
Channel name overflows

Description of problem:  The button text on the subscription details channel button can overflow the cell that contains it, causing an undesirable layout.


Version-Release number of selected component (if applicable):  4.5


Steps to Reproduce:
1.  Install etcd operator
2.  Visit https://<hostname>/k8s/ns/<namespace>/operators.coreos.com~v1alpha1~Subscription/etcd/
3.  Note `singlenamespace-alpha` overflows the cell

See attached screenshot.

Comment 3 Yanping Zhang 2020-04-26 07:10:34 UTC
Checked on ocp 4.5 cluster with payload 4.5.0-0.nightly-2020-04-25-170442.
Install operator etcd in project, then check on "Subscription" tab, the channel button text "singlenamespace-alpha" is shown correctly in two lies in cell.

Hi Robb, I install "Argo CD" operator which only one channel is available, and check on "Subscription" tab, found the pencil icon is still besides the channel name, it should be removed according to pr https://github.com/openshift/console/pull/5158, right?

Comment 4 Robb Hamilton 2020-04-27 12:11:50 UTC
(In reply to Yanping Zhang from comment #3)

> Hi Robb, I install "Argo CD" operator which only one channel is available,
> and check on "Subscription" tab, found the pencil icon is still besides the
> channel name, it should be removed according to pr
> https://github.com/openshift/console/pull/5158, right?

Sorry for the confusion.  No, the pencil icon should still be present is the channel is editable regardless of the number of channel options available.  The pencil icon is only removed if the channel is not editable.

Comment 5 Yanping Zhang 2020-04-28 03:33:52 UTC
Robb, thanks!
According to comment 3, when operator installation is not finished, the channel is not editable, and pencil icon is not shown. 
The bug is fixed.

Comment 6 errata-xmlrpc 2020-07-13 17:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.