Bug 1826962 - In topology view, user has given infinite zoom in and zoom out
Summary: In topology view, user has given infinite zoom in and zoom out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-22 21:00 UTC by Jeff Phillips
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-04-20-135811 Cluster ID: 058c878a-837f-4e84-bcf3-cad234552771 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.113 Safari/537.36
Last Closed: 2020-07-13 17:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
limit in zoom in and zoom out (625.51 KB, video/mp4)
2020-05-04 12:02 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5160 0 None closed Bug 1826962: Limit the amount a user can zoom in/out in topology 2020-06-23 10:16:44 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:43 UTC

Description Jeff Phillips 2020-04-22 21:00:10 UTC
Description of problem:

The user is able to use the zoom in and zoom out buttons in the topology view to zoom in so far or out so far as to make the view useless.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Create some workloads
2. Click on zoom in button many times till you tired and it will continue zooming in.
3. Do the same thing with zoom out and you will observe that it will continue to zoom out even though it is impossible to human eye to see the workloads.

Actual results:

Zoom levels are not bounded

Expected results:

Zoom button zooming should have the same bounds as using the wheel on the mouse.

Additional info:

Comment 3 Gajanan More 2020-05-04 12:02:02 UTC
Created attachment 1684791 [details]
limit in zoom in and zoom out

Comment 4 Gajanan More 2020-05-04 12:02:41 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-05-03-172622
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared video
Marking this as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.