Bug 1827042 - TechPreview Badge needs to be removed from Serverless
Summary: TechPreview Badge needs to be removed from Serverless
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1828717
TreeView+ depends on / blocked
 
Reported: 2020-04-23 06:35 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: DevConsole UI shows techPreview badge for Serverless and with 1.7.1 Serverless operator it went GA Consequence: User will See TechPreview badge in UI for knativeService Fix: Remove the TechPreview badge Result: User will not see techPreview badge for knative Service
Clone Of:
: 1828717 1829046 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
No TechPreview badge (135.18 KB, image/png)
2020-05-11 07:52 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5164 None closed Bug 1827042: removes techpreview badge from serverless 2020-08-20 04:53:01 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:30:43 UTC

Description Jaivardhan Kumar 2020-04-23 06:35:59 UTC
Description of problem: As serverless is going GA on 29th April so needed to remove TP badge across console for Serverless and this change needs to be back ported to 4.4


Version-Release number of selected component (if applicable): 4.4


How reproducible: Always


Steps to Reproduce:
1. Install Serverless Operator
2. Check in Add/Search flows, can see TechPreview for knative Service/Revision etc


Actual results: Tech-preview badge is shown for serverless in console


Expected results: Going forward Tech-preview badge should not be shown for serverless in console


Additional info:

Comment 3 Gajanan More 2020-05-11 07:52:38 UTC
Created attachment 1687174 [details]
No TechPreview badge

Comment 4 Gajanan More 2020-05-11 07:54:24 UTC
I have validated the bug on 
Build: 4.5.0-0.ci-2020-05-10-213458
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared.
Marking this as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.