Bug 1827050 - Operators may not respond to spec changes in managed deployments or daemonsets
Summary: Operators may not respond to spec changes in managed deployments or daemonsets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Maru Newby
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1827051 1827052
TreeView+ depends on / blocked
 
Reported: 2020-04-23 07:08 UTC by Maru Newby
Modified: 2020-07-13 17:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1827051 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-authentication-operator pull 272 0 None closed Bug 1827050: Update to use revised ApplyDeployment 2020-06-23 10:17:37 UTC
Github openshift cluster-image-registry-operator pull 550 0 None closed Bug 1827050: Update to use revised ApplyDeployment 2020-06-23 10:17:37 UTC
Github openshift cluster-openshift-apiserver-operator pull 354 0 None closed Bug 1827050: Update to use revised ApplyDeployment 2020-06-23 10:17:37 UTC
Github openshift console-operator pull 421 0 None closed Bug 1827050: Update to use revised ApplyDeployment 2020-06-23 10:17:37 UTC
Github openshift machine-api-operator pull 589 0 None closed Bug 1827050: Update to use revised ApplyDeployment 2020-06-23 10:17:37 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:43 UTC

Description Maru Newby 2020-04-23 07:08:33 UTC
Operators that rely on library-go's Apply{DaemonSet,Deployment} function were previously responsible for detecting changes to a managed resource's spec or changes to external resources and forcing a reload. All operators should be updated to use the revised Apply* methods recently merged to library-go [1] to ensure consistent behavior in responding to changes in external resources or changes to the spec of a managed deployment or daemonset.

1: https://github.com/openshift/library-go/pull/773

Comment 1 Maru Newby 2020-05-20 14:19:12 UTC
Still need to update the service ca operator for 4.5.

Comment 4 Maru Newby 2020-05-21 19:43:51 UTC
Note that this is an umbrella bz. As per the linked github PRs, if testing is to be done, it should be done for all updated operators.

Comment 5 Xingxing Xia 2020-06-19 12:08:35 UTC
No regression issue found related in QE latest 4.5 nightly builds' functional tests and upgrade tests so far.
Specifically take openshiftapiserver for example, rolling out has no regression issue (tested in 4.5.0-0.nightly-2020-06-18-210518 env)
$ oc edit project.config cluster # add below
...
spec:
  projectRequestMessage: xxia test projectRequestMessage change
...

$ oc get openshiftapiserver cluster -o yaml
...
spec:
...
    projectConfig:
      projectRequestMessage: xxia test projectRequestMessage change
...

$ oc get po -n openshift-apiserver # can see rolling out success.

Comment 7 errata-xmlrpc 2020-07-13 17:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.