Bug 1827061 - Missing line break cause output hard to read
Summary: Missing line break cause output hard to read
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 07:34 UTC by Liang Xia
Modified: 2020-07-13 17:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 396 0 None closed Bug 1827061: add missing newline 2020-06-23 10:17:41 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:44 UTC

Description Liang Xia 2020-04-23 07:34:20 UTC
Description of problem:
Trying to remove a cluster role from a group with command,
"oc adm policy remove-cluster-role-from-group system:build-strategy-docker system:authenticated"
Missing line break cause output hard to read

Version-Release number of selected component (if applicable):
openshift-clients-4.3.14-202004180552.git.1.a7a610a.el7.x86_64
Client Version: 4.3.14-202004180552-4fb2d4d
Server Version: 4.3.13
Kubernetes Version: v1.16.2

How reproducible:
Always

Steps to Reproduce:
1. oc adm policy remove-cluster-role-from-group system:build-strategy-docker system:authenticated

Actual results:
$ oc adm policy remove-cluster-role-from-group system:build-strategy-docker system:authenticated
Warning: Your changes may get lost whenever a master is restarted, unless you prevent reconciliation of this rolebinding using the following command: oc annotate clusterrolebinding.rbac system:build-strategy-docker-binding 'rbac.authorization.kubernetes.io/autoupdate=false' --overwriteclusterrole.rbac.authorization.k8s.io/system:build-strategy-docker removed: "system:authenticated"


Expected results:
$ oc adm policy remove-cluster-role-from-group system:build-strategy-docker system:authenticated
Warning: Your changes may get lost whenever a master is restarted, unless you prevent reconciliation of this rolebinding using the following command: oc annotate clusterrolebinding.rbac system:build-strategy-docker-binding 'rbac.authorization.kubernetes.io/autoupdate=false' --overwrite
clusterrole.rbac.authorization.k8s.io/system:build-strategy-docker removed: "system:authenticated"


Additional info:

Comment 3 zhou ying 2020-05-06 03:00:52 UTC
[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: "2020-05-02T15:23:53Z"
  compiler: gc
  gitCommit: 29e9a330f0ab0eed17b5ba6a8cc198ccc4332567
  gitTreeState: clean
  gitVersion: 4.5.0-202005021517-29e9a33
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64


[root@dhcp-140-138 ~]# oc adm policy remove-cluster-role-from-group system:build-strategy-docker system:authenticated
Warning: Your changes may get lost whenever a master is restarted, unless you prevent reconciliation of this rolebinding using the following command: oc annotate clusterrolebinding.rbac system:build-strategy-docker-binding 'rbac.authorization.kubernetes.io/autoupdate=false' --overwrite
clusterrole.rbac.authorization.k8s.io/system:build-strategy-docker removed: "system:authenticated"

Comment 4 errata-xmlrpc 2020-07-13 17:30:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.