Bug 1827062 - FSType is empty when using default cinder storageclass to create a pv
Summary: FSType is empty when using default cinder storageclass to create a pv
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Christian Huffman
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 07:37 UTC by Chao Yang
Modified: 2020-07-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24990 0 None closed Bug 1827062: UPSTREAM: 90608: Updates the fstype of Cinder volumes to be ext4 if nil 2020-07-02 21:36:09 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:44 UTC

Description Chao Yang 2020-04-23 07:37:42 UTC
Description of problem:
FSType is empty when using cinder default storageclass to create a pv

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-18-184707

How reproducible:
Always

Steps to Reproduce:
1.Create a dynamic pv with default storageclass
2.oc describe pv
oc describe pv pvc-7fb50215-9276-4c64-8f0a-d63de849f602
Name:              pvc-7fb50215-9276-4c64-8f0a-d63de849f602
Labels:            failure-domain.beta.kubernetes.io/region=
                   failure-domain.beta.kubernetes.io/zone=nova
Annotations:       kubernetes.io/createdby: cinder-dynamic-provisioner
                   pv.kubernetes.io/bound-by-controller: yes
                   pv.kubernetes.io/provisioned-by: kubernetes.io/cinder
Finalizers:        [kubernetes.io/pv-protection]
StorageClass:      standard
Status:            Bound
Claim:             test/pvc1
Reclaim Policy:    Delete
Access Modes:      RWO
VolumeMode:        Filesystem
Capacity:          1Gi
Node Affinity:     
  Required Terms:  
    Term 0:        failure-domain.beta.kubernetes.io/zone in [nova]
Message:           
Source:
    Type:       Cinder (a Persistent Disk resource in OpenStack)
    VolumeID:   ece31599-6eac-43fb-96a2-cdeecc1f8996
    FSType:     
    ReadOnly:   false
    SecretRef:  nil
Events:         <none>

3.FSType is empty

Actual results:
FSType is empty

Expected results:
FSType is ext4
Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Christian Huffman 2020-04-23 19:50:50 UTC
Is this an actual issue?

From the API types:

	// Filesystem type to mount.
	// Must be a filesystem type supported by the host operating system.
	// Ex. "ext4", "xfs", "ntfs". Implicitly inferred to be "ext4" if unspecified.
	// +optional
	FSType string

If this is unspecified, then it is inferred to be ext4.

Comment 2 Chao Yang 2020-04-29 08:35:44 UTC
It is not an actual issue. so I set the priority is low.

We can update it in our code or docs

Comment 5 Christian Huffman 2020-05-15 18:07:52 UTC
Commit has been merged upstream, submitting https://github.com/openshift/origin/pull/24990 to include this in origin.

Comment 8 Chao Yang 2020-05-25 10:20:04 UTC
Verification is passed on 4.5.0-0.ci-2020-05-25-012555
oc describe pv
Name:              pvc-eb6f433b-7ec2-427b-8700-76500d76a777
Labels:            failure-domain.beta.kubernetes.io/region=regionOne
                   failure-domain.beta.kubernetes.io/zone=nova
Annotations:       kubernetes.io/createdby: cinder-dynamic-provisioner
                   pv.kubernetes.io/bound-by-controller: yes
                   pv.kubernetes.io/provisioned-by: kubernetes.io/cinder
Finalizers:        [kubernetes.io/pv-protection]
StorageClass:      standard
Status:            Bound
Claim:             default/pvc1
Reclaim Policy:    Delete
Access Modes:      RWO
VolumeMode:        Filesystem
Capacity:          1Gi
Node Affinity:     
  Required Terms:  
    Term 0:        failure-domain.beta.kubernetes.io/zone in [nova]
                   failure-domain.beta.kubernetes.io/region in [regionOne]
Message:           
Source:
    Type:       Cinder (a Persistent Disk resource in OpenStack)
    VolumeID:   a474841c-5958-4dd6-8827-a81757c371fa
    FSType:     ext4
    ReadOnly:   false
    SecretRef:  nil
Events:         <none>

Comment 9 errata-xmlrpc 2020-07-13 17:30:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.