Bug 1827071 - The info message is not clear when try to resize a cinder pv
Summary: The info message is not clear when try to resize a cinder pv
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jan Safranek
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 08:05 UTC by Chao Yang
Modified: 2020-07-13 17:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24987 0 None closed Bug 1827071: UPSTREAM: 90792: Send a nicer event when resizing attached Cinder volume 2020-07-01 09:12:31 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:30:44 UTC

Description Chao Yang 2020-04-23 08:05:11 UTC
Description of problem:
The info message is not clear when try to resize a cinder pv

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-18-184707

How reproducible:
Always

Steps to Reproduce:
1.Create pvc,pod
2.Try to resize the pv, update pvc requested size
3.oc describe pvc

 Warning  VolumeResizeFailed          2m26s (x14 over 3m8s)  volume_expand                       error expanding volume "default/pvc1" of plugin "kubernetes.io/cinder": volume in in-use status can not be expanded, it must be available and not attached to a node

Actual results:
This error msg is not friendly and clear for end user.

Expected results:
error msg such as: PVC is consumed by a Pod can not be expanded, please ensure the PVS is not used by any Pod.

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Hemant Kumar 2020-04-23 15:29:43 UTC
This was previously accepted in a BZ and error message was deemed acceptable - https://bugzilla.redhat.com/show_bug.cgi?id=1744893 .

Comment 2 Jan Safranek 2020-05-06 09:44:54 UTC
Upstream PR: https://github.com/kubernetes/kubernetes/pull/90792

Comment 5 Chao Yang 2020-05-25 10:29:43 UTC
Verification is passed on 4.5.0-0.ci-2020-05-25-012555

  Warning  VolumeResizeFailed     43s (x19 over 22m)  volume_expand                error expanding volume "default/pvc1" of plugin "kubernetes.io/cinder": PVC used by a Pod can not be expanded, please ensure the PVC is not used by any Pod and is fully detached from a node

Comment 6 errata-xmlrpc 2020-07-13 17:30:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.