Bug 1827156 - Tolerations in VM details does not find node even there is matching node
Summary: Tolerations in VM details does not find node even there is matching node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Gilad Lekner
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 11:23 UTC by Guohua Ouyang
Modified: 2020-07-13 17:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5269 0 None closed Bug 1827156: Tolerations in VM details does not find node 2020-07-13 14:59:16 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:03 UTC

Description Guohua Ouyang 2020-04-23 11:23:44 UTC
Description of problem:
Add a taint "kubevirt.io=123:NoSchedule" to a node and add the same key/value as toleration to vm on VM details, it does not find the node on vm details.

It seems is querying the labels instead of taints.


Version-Release number of selected component (if applicable):
master

How reproducible:
100%

Steps to Reproduce:
1. Add taint "kubevirt.io=123:NoSchedule" to a node.
2. Add toleration "kubevirt.io=123:NoSchedule" to a vm.
3. 

Actual results:
It does not find the node on vm details.

Expected results:
The node with taint "kubevirt.io=123:NoSchedule" should be found.

Additional info:

Comment 3 Guohua Ouyang 2020-05-13 05:58:22 UTC
verified on 4.5.0-0.nightly-2020-05-12-065413.

Comment 4 errata-xmlrpc 2020-07-13 17:30:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.