Bug 18272 - tkmib doesn't work with default install
Summary: tkmib doesn't work with default install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
: 16582 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-03 22:50 UTC by Jules Agee
Modified: 2015-03-05 01:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 18:33:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jules Agee 2000-10-03 22:50:15 UTC
After installing RedHat 7.0 with the ucd-snmp and ucd-snmp-utils rpms, it
was a big pain-in-the-tuckus to get tkmib working, and it shouldn't have
been. Here's the saga:

1) tkmib complains about missing tk.pm (doesn't complain about missing
any other dependencies). 

2) No problem - downloaded, compiled, installed tk.pm. 

3) Run it again - now tkmib complains about missing SNMP.pm. Irritating
- how many more modules am I missing? View tkmib source - nope, that's
it, just tk and SNMP modules are used...

4) Download SNMP.pm package from CPAN. Makefile.PL asks for location of
ucd-snmp include files. Don't have any - I installed from the binary RPM,
which apparently doesn't install these. Grrr.

5) Download ucd-snmp source RPM, and install. Untar the sources. View
SNMP.pm's Makefile.PL, to figure out exactly which include files it's
looking for. It apparently is seeking a directory called ucd-snmp,
containing such goodies as ucd-snmp-config.h, with many others. It expects
this directory to be in /usr/local/include. 

In order to get this to work correctly, I have to install ucd-snmp from the
.tar.gz distribution, which installs the include files that SNMP.pm needs
that weren't installed by the RPM. Then SNMP.pm installs, and tkmib works.

Comment 1 Jeff Johnson 2000-10-12 15:44:20 UTC
*** Bug 16582 has been marked as a duplicate of this bug. ***

Comment 2 Wes Hardaker 2001-02-14 16:29:32 UTC
The perl CPAN module needs updating and a SNMP perl module RPM could really be used (as well as a Tk perl module rpm).



Note You need to log in before you can comment on or make changes to this bug.