Bug 182720 - DRI corruption/performance problems with ati driver on S1XP
DRI corruption/performance problems with ati driver on S1XP
Status: CLOSED DUPLICATE of bug 182196
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 04:47 EST by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 07:30:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of screen corruption at top left of screen (186.52 KB, image/png)
2006-02-25 08:19 EST, Duncan Innes
no flags Details
X server log when problem occurs (39.71 KB, text/plain)
2006-03-01 17:13 EST, Adam Huffman
no flags Details
X config file (3.10 KB, text/plain)
2006-03-01 17:14 EST, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2006-02-24 04:47:11 EST
Description of problem:
There seem to be several related problems with the ati driver on a Vaio S1XP
laptop in FC5 test 3.  There is occasional corruption at the top and bottom of
the screen, when returning to X from a console.
More seriously the X server appears to be locking up for minutes at a time,
rendering the system unusable during that period.  When running top as root, the
Xorg process is taking up 99% CPU during these 'outbursts'.
The problem may be specifically with the DRI part of the driver as I have booted
with the Load DRI directive commented out and the problem - while still there -
is much less serious.  That is to say X is still taking up too much CPU time but
the desktop is still usable.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7.3-4

How reproducible:
Always

Steps to Reproduce:
1. Boot the laptop
2. Login to the desktop
3.
  
Actual results:
X periodically takes up all available CPU

Expected results:
X should operate normally

Additional info:
Comment 1 Duncan Innes 2006-02-25 08:06:23 EST
Don't know if this is helpful or not but:

I have Thinkpad T40 with Radeon Mobility M7 LW [Radeon Mobility 7500].

I've not seen any rogue CPU usage, but I HAVE seen screen corruption at the top
of the screen.  Just searching for any dupes of this behaviour and this bug is
the closest I've seen.

The corruption is limited to the top menubar under Gnome (not tried KDE) and
extends in from the left to roughly half way across the "Places" menu title. 
Corruption disappears when you select those menus and they get redrawn.  As luck
would have it, the corruption isn't there right now, but I'll post a screenshot
as soon as I can.

Duncan
Comment 2 Duncan Innes 2006-02-25 08:19:43 EST
Created attachment 125243 [details]
Screenshot of screen corruption at top left of screen

Corruption disappears when the menus are selected.  Corruption also changes
slightly after period of time - not sure how long, but I can now read the
Applications and Places menu titles clearly although they still have a red
streak behind them and the 'f' icon background is a bit garbled.
Comment 3 Duncan Innes 2006-02-25 08:22:27 EST
Am running Xen hypervisor kernel BTW if this makes a difference - uninstalling
now to see if corruption still evident under normal kernel.
Comment 4 Duncan Innes 2006-02-27 06:27:36 EST
Haven't seen any corruption since the re-install without the Xen hypervisor.

Is this a Xen issue?
Comment 5 Mike A. Harris 2006-02-28 02:21:08 EST
It's good to know if Xen is influencing the problem at all or not.  From
there though, it could be a Xen kernel bug, or an X bug, or something
else perhaps.

Update to the latest Fedora development packages, including the kernel,
and then while booted in the kernel that reproduces the problem, please
attach your X server log and config file from that invocation for
further diagnosis.

Try disabling DRI, and also try disabling 2D acceleration with Option "noaccel"
also if the problem is still present in the current rawhide kernels.

TIA
Comment 6 Adam Huffman 2006-03-01 17:12:02 EST
I can confirm that the problem persists when running the latest kernel (1.1996)
with the latest updates, when DRI is enabled.  No such problems when DRI is
disabled.

Comment 7 Adam Huffman 2006-03-01 17:13:41 EST
Created attachment 125500 [details]
X server log when problem occurs
Comment 8 Adam Huffman 2006-03-01 17:14:36 EST
Created attachment 125501 [details]
X config file

This is the current version, with DRI disabled.  The problem occurs when DRI is
enabled.
Comment 9 Mike A. Harris 2006-03-07 07:27:06 EST
Seems to be a bug in the radeon kernel module on R300 hardware, which
occurs when the kernel module is loaded, even if userland does not have
r300 DRI support.

Comment 10 Mike A. Harris 2006-03-07 07:30:07 EST

*** This bug has been marked as a duplicate of 182196 ***

Note You need to log in before you can comment on or make changes to this bug.