Bug 1827204 - Knative service revision deployments should not be editable from topology list view
Summary: Knative service revision deployments should not be editable from topology lis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: divgupta
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 12:30 UTC by divgupta
Modified: 2020-07-13 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
No edit service in list view (168.87 KB, image/png)
2020-05-08 05:14 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5166 0 None closed Bug 1827204: Knative service revision deployments should not be editable via add flows 2020-06-23 10:20:09 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:03 UTC

Description divgupta 2020-04-23 12:30:20 UTC
Description of problem:

Knative service revision deployments which are not created using add flows are still editable from topology list view.

Steps to Reproduce:
1. Install the OpenShift Serverless Operator
2. Create Knative service using one of the add flow
3. Go to the list view and click on the knservice revision deployment and then click on actions dropdown in the sidebar, see that editing using the add flows is enabled.

Actual results:
Knative service revision deployments are editable using the add flows


Expected results:
Knative service revision deployments should not be editable using the add flows since they are not created using the add flows.

Comment 3 Gajanan More 2020-05-08 05:14:30 UTC
Created attachment 1686373 [details]
No edit service in list view

Comment 4 Gajanan More 2020-05-08 05:14:51 UTC
I have validated the bugzilla on
Build: 4.5.0-0.ci-2020-05-06-053625
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot
Marking this as a verified.

Comment 5 errata-xmlrpc 2020-07-13 17:30:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.