Bug 1827218 - List Pages do not update `Created` column unless the resource itself updates
Summary: List Pages do not update `Created` column unless the resource itself updates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 12:48 UTC by Filip Krepinsky
Modified: 2020-07-13 17:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The Created timestamp in resource list pages display using a component that does not dynamically update. Consequence: The Created timestamps in resource list pages can be out dated, especially for newly created resources that are less than an hour old. Fix: The Created timestamp in resource list pages now displays using the Timestamp component, which dynamically updates. Result: Created timestamps in resource list pages now dynamically update to accurately reflect the time created.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5185 0 None closed Bug 1827218: change instances of `fromNow` to `<Timestamp>` in Creat… 2020-06-23 10:21:08 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:03 UTC

Description Filip Krepinsky 2020-04-23 12:48:45 UTC
Description of problem:
Created time is also not updated in detail pages in first few minutes

How reproducible:
100

Steps to Reproduce:
1. Create a simple Pod in custom namespace
2. Wait until all pod updates change (conditions, etc.) 
3. Go to the list
4. wait few minutes
5. Created relative time does not update


Expected results:
Relative time should be updated accordingly.

Possible solution:

All usages of fromNow and timestampFor functions could be used as hooks which would update the value after some delay. The delay could increase with the time (for example: every few second in the begginning, and every minute a bit later, etc.)

Comment 3 XiaochuanWang 2020-04-27 05:54:29 UTC
Created pods are updating the Created column now.
Verified on 4.5.0-0.nightly-2020-04-26-203839

Comment 4 errata-xmlrpc 2020-07-13 17:30:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.