Bug 1827259 - Windows VM is in Stopping status after a while of running
Summary: Windows VM is in Stopping status after a while of running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 13:48 UTC by Radim Hrazdil
Modified: 2020-07-13 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
VM resources (5.24 KB, application/zip)
2020-04-23 13:48 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5297 0 None closed Bug 1827259: kubevirt: fix VM statuses 2020-10-15 11:40:42 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:11 UTC

Description Radim Hrazdil 2020-04-23 13:48:00 UTC
Created attachment 1681158 [details]
VM resources

Description of problem:

When a user creates and starts up a Windows VM, after a while of running the VM has Status Stopping.

VM Events gives an error about Readiness probe:
Readiness probe errored: rpc error: code = Unknown desc = container is not created or running


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a Windows VM, start it, wait
2.
3.

Actual results:
VM is in Stopping status

Comment 1 Radim Hrazdil 2020-04-23 13:49:35 UTC
Assigning to Filip after offline discussion

Comment 4 Radim Hrazdil 2020-05-27 09:13:37 UTC
This bug was discovered due to another bug where a running virt-launcher crashed, which incorrectly caused the VM to report status Stopping instead of Pod Error.
Since I'm not able to reproduce this, I can't verify the VM Status transition Running -> Pod Error.

I have verified that VM Status reports correctly for regular situations and with a virt-launcher pod in Error state. 
Verified with release-4.5 commit: 91e682e014286e243085dcb168480d54b913a010

Comment 5 errata-xmlrpc 2020-07-13 17:30:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.