Bug 1827297 - Resource limit throws validation error on changing units
Summary: Resource limit throws validation error on changing units
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Debsmita Santra
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 15:05 UTC by Debsmita Santra
Modified: 2020-07-13 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
resource limits (1.21 MB, video/mp4)
2020-04-28 12:27 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5172 0 None closed Bug 1827297: Fix resource limits validation error 2020-06-23 10:21:18 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:11 UTC

Description Debsmita Santra 2020-04-23 15:05:04 UTC
Description of problem:
Resource Limit in the advanced section of the import form throws validation error on changing units although the values are consistent with the validation condition.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. Go to the Import from git form
2. In the Advanced Options, click on Resource Limits
3. Enter values for Cpu request and limit. Change the request unit to cores 

Actual results:
The validation fails. No error is being displayed if the request value is higher than the limit.

Expected results:
Proper error message should be displayed if the request value is higher than the limit.

Additional info:

Comment 3 Gajanan More 2020-04-28 12:24:33 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.ci-2020-04-27-195432
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot.
Marking this bugzilla as verified.

Comment 4 Gajanan More 2020-04-28 12:27:49 UTC
Created attachment 1682456 [details]
resource limits

Comment 5 errata-xmlrpc 2020-07-13 17:30:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.