Bug 182734 - gnome-panel doesn't handle profile argument anymore
gnome-panel doesn't handle profile argument anymore
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-24 07:20 EST by Daniel Malmgren
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 14:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 332486 None None None Never

  None (edit)
Description Daniel Malmgren 2006-02-24 07:20:15 EST
Description of problem:
When I tried to start my system after yesterdays rawhide update I ended up with
no panels on my screen. After some searching I found out that ~/.gnome2/session
looks like this:

---snip---
1,CloneCommand=gnome-panel --sm-config-prefix /gnome-panel-Bz42Bk/ --profile default
1,RestartCommand=gnome-panel --sm-config-prefix /gnome-panel-Bz42Bk/
--sm-client-id 117f000001000103384436800000008480002 --screen 0 --profile default
---snip---

...which doesn't work because gnome-panel says that is hasn't got any
"--profile" argument. Removing that argument made everything work again. Not
sure where to file this, but this must be a bug, right?

Version-Release number of selected component (if applicable):
gnome-session-2.13.91-1
gnome-panel-2.13.91-3
Comment 1 Ray Strode [halfline] 2006-02-24 14:58:43 EST
Hi,

I've filed an upstream bug report here:

http://bugzilla.gnome.org/show_bug.cgi?id=332486
Comment 2 Matthias Clasen 2006-02-25 00:03:00 EST
Hmm, --profile was removed in 2004:

2004-11-12  Mark McLoughlin  <mark@skynet.ie>

	Back in 2.4, we messed up by not realising that the new
	configuration format didn't in fact co-exist at all well
	with the 2.2 configuration. Which means if you share a
	homedir between a GNOME 2.2 (or before) login and a
	GNOME 2.4 (or later) login, you're panel is screwed
	terribly.

	This change belatedly fixes the problem by storing the
	panel configuration in a different location from where
	we stored it in GNOME 2.2. It also removes the broken
	concept of panel profiles. The new layout is the same
	as before except its store in /apps/panel now - e.g. the
	list of panels is now /apps/panel/general/toplevel_id_list

	* Makefile.am: install the default setup in /apps/panel.

	* main.c: (main): remove the --profile command line argument.


Why does this suddenly become a problem ? Did popt silently ignore --profile ?
Comment 3 Ray Strode [halfline] 2006-02-25 17:24:29 EST
That'd be my guess.  Popt either ignored it or just warned and Goption errors
and exits.
Comment 4 Ray Strode [halfline] 2006-02-27 14:03:58 EST
should be fixed in tomorrow's rawhide.

Note You need to log in before you can comment on or make changes to this bug.