Bug 1827357 - GCC bug which doesn't let Erlang handling more than 79 command line args
Summary: GCC bug which doesn't let Erlang handling more than 79 command line args
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL: https://bugs.erlang.org/browse/ERL-1233
Whiteboard: Reproducer
: 1830137 1830143 1833792 1833793 1833794 1835649 1836156 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 17:31 UTC by Peter Lemenkov
Modified: 2020-10-05 08:30 UTC (History)
12 users (show)

Fixed In Version: gcc-10.0.1-0.13.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 04:56:19 UTC
Type: Bug


Attachments (Terms of Use)
Reproducer (1.64 KB, text/x-csrc)
2020-04-23 17:31 UTC, Peter Lemenkov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 94734 0 P1 RESOLVED [10 Regression] Program crashes when compiled with -O2 since r10-1892-gb9ef6a2e04bfd013 2020-10-05 08:57:48 UTC

Description Peter Lemenkov 2020-04-23 17:31:32 UTC
Created attachment 1681214 [details]
Reproducer

We've stumbled upon a bug in GCC 10 which doesn't let us to compile RabbitMQ with Erlang compiled with GCC 10. Fortunately Erlang upstream developers nailed it down to a simple reproducer see file attached).

I've tested Rawhide and F-32 - both versions are affected.

Comment 1 Fedora Update System 2020-05-01 20:01:34 UTC
FEDORA-2020-f5cb410216 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f5cb410216

Comment 2 Fedora Update System 2020-05-02 05:54:25 UTC
FEDORA-2020-f5cb410216 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f5cb410216`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f5cb410216

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2020-05-04 04:56:19 UTC
FEDORA-2020-f5cb410216 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Peter Lemenkov 2020-05-14 20:21:25 UTC
*** Bug 1830137 has been marked as a duplicate of this bug. ***

Comment 5 Peter Lemenkov 2020-05-14 20:21:44 UTC
*** Bug 1835649 has been marked as a duplicate of this bug. ***

Comment 6 Peter Lemenkov 2020-05-14 20:22:21 UTC
*** Bug 1830143 has been marked as a duplicate of this bug. ***

Comment 7 Peter Lemenkov 2020-05-14 20:22:24 UTC
*** Bug 1833792 has been marked as a duplicate of this bug. ***

Comment 8 Peter Lemenkov 2020-05-14 20:25:03 UTC
*** Bug 1833793 has been marked as a duplicate of this bug. ***

Comment 9 Peter Lemenkov 2020-05-14 20:26:26 UTC
*** Bug 1833794 has been marked as a duplicate of this bug. ***

Comment 10 Peter Lemenkov 2020-05-15 10:10:19 UTC
*** Bug 1836156 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.