Bug 1827392 - communication between pods on linux and windows nodes fail
Summary: communication between pods on linux and windows nodes fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Ben Bennett
QA Contact: huirwang
URL:
Whiteboard:
Depends On: 1827391
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-23 19:37 UTC by jtanenba
Modified: 2020-05-04 11:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1827391
Environment:
Last Closed: 2020-05-04 11:50:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 147 None closed [release-4.4] Bug 1827392: hybrid-overlay: fix podChanged() return values 2020-04-28 14:25:54 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:50:18 UTC

Description jtanenba 2020-04-23 19:37:07 UTC
+++ This bug was initially created as a clone of Bug #1827391 +++

Description of problem:

Linux and windows pods cannot communicate with each other

Version-Release number of selected component (if applicable):


How reproducible:

everytime 


Steps to Reproduce:
1. deploy an openshift cluster with hybrid networking 
2. deploy a windows node 
3. deploy a webserver pod on the windows node 
4. deploy a client pod on a linux node 
5. attempt to network communication between the pods on the windows and linux nodes

Actual results:
traffic does not get routed between the windows and linux pods

Expected results:
traffic can flow from the windows and linux pods 


Additional info:

--- Additional comment from  on 2020-04-23 19:35:50 UTC ---

along with https://github.com/openshift/cluster-network-operator/pull/604 should fully fix current windows networking issues

Comment 2 Ben Bennett 2020-04-24 17:49:34 UTC
This is isolated to the windows gateway code... and that is already broken by this, so it can get no worse.  So moving back to 4.4.0.

Comment 8 zhaozhanqi 2020-04-29 11:15:30 UTC
Just have a discuss with sgao who setup the windows worker cluster

The windows worker is using the old veresion hybird-overly.exe from https://github.com/openshift/windows-machine-config-bootstrapper/releases/tag/v4.4.3-alpha

maybe it caused the pod cannot be communicated between windows and linux pod

Comment 12 errata-xmlrpc 2020-05-04 11:50:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.