Bug 1827457 - specDescriptors fieldDependency not working as expected
Summary: specDescriptors fieldDependency not working as expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Yu Zhao
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1835775 (view as bug list)
Depends On: 1826074
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-24 01:32 UTC by Yadan Pei
Modified: 2020-06-02 11:18 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
What was broke: The “fieldDependency” specDescriptor doesn’t work properly, control field cannot control the visibility of the dependency field What was fixed: The “fieldDependency” specDescriptor works properly, the visibility of dependency field is correctly controlled by control field.
Clone Of: 1826074
Environment:
Last Closed: 2020-06-02 11:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5157 None closed Bug 1827457: Fixed the issue for fieldDependency spec descriptor for create operan… 2020-06-18 14:23:10 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:18:29 UTC

Comment 1 Cyril 2020-04-27 19:40:36 UTC
This bug is a clone of https://bugzilla.redhat.com/show_bug.cgi?id=1826074. Yu worked on the original bug, so I assigned it to him.

Comment 2 Jon Jackson 2020-05-15 16:04:05 UTC
*** Bug 1835775 has been marked as a duplicate of this bug. ***

Comment 5 shahan 2020-05-26 04:18:25 UTC
Install Install "Business Automation" Operator, in CSV, add 
   "- 'urn:alm:descriptor:com.tectonic.ui:fieldDependency:upgrades.enabled:true'"
   as one of the "x-descriptors" for "path: upgrades.minor" specDescriptor field
Create instance, on the "Form View", see "Enable Upgrades" is default as false, and "Include minor version upgrades" doesn't show up.
Set "Enable Upgrades" as "True", "Include minor version upgrades" shows up and could be set true/false.

4.4.0-0.nightly-2020-05-25-115719

Comment 7 errata-xmlrpc 2020-06-02 11:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.