Bug 1827490 - [IPI on BM] Bare Metal Hosts Details page always shows a loading icon for Pods when BMH is in inspection error status
Summary: [IPI on BM] Bare Metal Hosts Details page always shows a loading icon for Pod...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-24 03:42 UTC by Yadan Pei
Modified: 2020-07-13 17:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Pods are determined by BMH Node. In some cases Node is not available. Consequence: Pods item in Overview page keeps loading Fix: Detect when BMH Node is not available Result: Pods items shows 0 pods instead of loading state
Clone Of:
Environment:
Last Closed: 2020-07-13 17:30:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
0 Pods are shown (407.76 KB, image/png)
2020-06-17 03:00 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5564 None closed Bug 1827490: Show 0 pods if node or machine is missing for BMH 2020-09-17 09:49:01 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:31:19 UTC

Description Yadan Pei 2020-04-24 03:42:28 UTC
Description of problem:
When a BMH is in 'Inspection error' status, it always shows a loading icon in Inventory card on BMH details page

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-04-18-095545

How reproducible:
Always

Steps to Reproduce:
1. Visit BMH details page from Nodes -> Bare Metal Hosts -> click the one in inspection error status
2. check Inventory card
3.

Actual results:
2. It always shows a loading icon besides 'Pods'

Expected results:
2. If there is no pods, we should show correct number 0 instead of always showing loading icon

Additional info:

Comment 3 Yadan Pei 2020-06-17 03:00:37 UTC
Created attachment 1697729 [details]
0 Pods are shown

When a BMH is in Registration error status, Bare Metal Host Details page shows '0 Pods' in Inventory card


Verified on 4.5.0-0.nightly-2020-06-11-183238

Comment 4 errata-xmlrpc 2020-07-13 17:30:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.