Bug 18276 - Upgrade 6.2 -> 7.0 Broke eth0 running Tulip Drivers
Upgrade 6.2 -> 7.0 Broke eth0 running Tulip Drivers
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 19:43 EDT by Brian Z
Modified: 2014-03-16 22:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 00:51:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Z 2000-10-03 19:43:33 EDT
My upgrade from 6.2 to 7.0 went very smooth, exect it broke the network
card.  To fix the problem, I entered linuxconfig, went to the eth0 setup,
and entered the hostname (under the eth0 tab - I don't remember if it was
previously entered) and changed the driver from old_tulip to tulip.  I
rebooted the computer and the card was working fine.  I would appreciate
this being fixed so other people don't have the same problem in the
future.  Thanks!
Comment 1 Ale Feltes Quenhan 2000-10-04 23:32:31 EDT
I had the same problem with rtl8139 drivers.
The module did not load and of course neither the interface. 
I did an upgrade from 6.9.5 (7.0beta) to 7.0
Comment 2 Michael Fulbright 2000-10-05 18:07:59 EDT
What are the PCI ids (try the lspci command) of your card? We use it do identify
the card and pick the right driver.
Comment 3 Brian Z 2000-10-05 18:39:22 EDT
My card is made my Netgear (FA310TX) and has the following id:
00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)

Thanks for your help!
Comment 4 Michael Fulbright 2000-10-06 17:35:49 EDT
Hi, 

 Please send the output from the 'lspci -n' command - the regular output didnt
have the info we needed.

Thanks.
Comment 5 Brian Z 2000-10-08 10:25:11 EDT
Here is the output for the ethernet card from lspci -n:

00:0a.0 Class 0200: 1011:0009 (rev 22)
Comment 6 Michael Fulbright 2000-11-07 14:54:18 EST
Currently kudzu (the hw probing module) assigns the "old_tulip" driver to this
particular PCI ID.

Assigning bug to kudzu component.
Comment 7 Bill Nottingham 2000-11-07 15:11:52 EST
We do not change the configured driver on upgrades currently;
it is assumed that the driver is properly configured before.

The old_tulip driver did not work correctly for you in 7.0?
Comment 8 Brian Z 2000-11-07 22:27:35 EST
No, for some reason I was losing a high rate of packets (just in my local network) and and it just wasn't working right.  I reset it to
tulip and also added a hostname (which I think was lost on the upgrade) and it fixed the problem.. If you would like, I can experiment
some more with dirvers and settigns and see what doesn't work :)
Comment 9 Need Real Name 2000-11-10 22:06:29 EST
I have the same problem when I went from 6.1 to 7.0 install went great, but my 
network card is broke.  I have a Netgear FA310-TX card and it worked fine on RH 
6.1, but the upgrade it stopped working.  When I boot It says: 
interface eth0: Determining IP information for eth0.... Operation failed.  

In netcfg it says that eth0 is active. I have even done a full reinstall of 
just 7.0 and same problem.  I know all the information about the IP and Netmask 
is all correct.  When I look in /etc/sysconfig/hwconf file under class Network 
it says: 
00:0f.0 Ethernet controller: LiteOne Communications Inc LNE100TX DECchip 21140
[FasterNet] (rev 20) 

and under driver it says ignore, but I thought my card needs a Tulip driver 
which I have tried to change to and still card is broke.  When I delete the 
class Network info from hwconf file and run Kudzu the same information comes 
back.  When I run 'lspci -n command' I get:
00:0f.0 class 0200: 11ad:0002 (rev 20) 

Also, at boot GET_LOCAL_HOST: 'localhost' IP address not available!

I know this is a problem with Red Hat 7.0 because two of my friends both 
upgraded from 6.1 to 7.0 and have different 3Com cards with the same problem.

I would appreciate any help with this problem!

I do not want to buy another NIC just found out that that one doesn't work too.

Thanks!
Comment 10 Bill Nottingham 2000-11-13 02:28:57 EST
What does your /etc/modules.conf say?
Comment 11 Need Real Name 2000-11-13 11:14:21 EST
/etc/modules.conf

alias parport_lowlevel parport_pc
alias usb-controller vsb-ohci
alias eth0 tulip

Also, my /etc/sysconfig/hwconf

-
class: NETWORK
bus: PCI
detailed: 0
device: eth
driver: ignore
desc: "Lite-On|LNE100TX"
vendorID: llad
deviceID: 0002
subvendorID: 1385
subdeviceID: f004
pciType: 1
-

Also I noticed /etc/sysconfig pcmcia  file says:

PCMCIA= no
PCIC=
PCIC_OPTS=
CORE_OPTS=

I'm really hoping someone could help me to solve this problem.

Thanks
Comment 12 Bill Nottingham 2000-11-13 12:04:02 EST
That *looks* OK. What happens if you do:

modprobe tulip
ifup eth0

Also, how are you configuring eth0 - statically, DHCP, something else?
If DHCP, what sort of DHCP setup/server are you talking to?
Comment 13 Need Real Name 2000-11-13 23:55:07 EST
modprobe tulip
ifup eth0

Determining IP information for eth0.... Operation failed.  
failed.

I have the IP set to static which the IP comes from my LinkSys router then to 
my cable company.
I have tried DHCP and static both, and both can not determine IP information 
for eth0, but right now I have it set to static IP 192.168.1.101
When I ran RH 6.1 I had the same Linksys to cable system that worked great.

When I run RH Network Monitor and click to activate the eth0 interface.  I get 
an error: fail to active interface, but in netconf it says that eth0 is active.

Thanks!
Comment 14 Bill Nottingham 2000-11-13 23:57:27 EST
The 'determining IP information' implies that it is trying
DHCP. What does /etc/sysconfig/network-scripts/ifcfg-eth0 say?
Comment 15 Need Real Name 2000-11-14 00:24:50 EST
Will it was on DHCP, but now it is static.  When I ran agian:
modprobe tulip
ifup eth0

I get:
SIOCSIFFLAGA: Network is down
SIOCADDRT: Network unreachable
SIOCADDRT: Network unreachable

And can put it back onto DHCP.


What does /etc/sysconfig/network-scripts/ifcfg-eth0 say?
device = "eth0"
appaddr = "192.168.1.101"
network = "255.255.255.0"
onboot = "yes"
bootproto = "none"
IPXNETNUM_802_2 = ""
IPXPRIMARY_802_2 = "no"
IPXACTIVE_802_2 = "no"
IPXNETNUM_802_3 = ""
IPXPRIMARY_802_3 = "no"
IPXACTIVE_802_3 = "no"
IPXNETNUM_ETHERII = ""
IPXPRIMARY_ETHERII = "no"
IPXNETNUM_SNAP= ""
IPXPRIMARY_SNAP= "no"
IPXACTIVE_SNAP= "no"

Thanks!


Comment 16 Bill Nottingham 2000-11-14 00:41:09 EST
What does /etc/sysconfig/network say?

Also, if you type 'dmesg', do you get any error messages from
the kernel related to the tulip driver?
Comment 17 Need Real Name 2000-11-14 01:09:16 EST
What does /etc/sysconfig/network say?
network=yes
hostname="bigb.webserver"
gatewaydev=eth0
gateway=192.168.1.1

then, type 'dmesg':
I did not get any errors with the kernel not any errors of any type, but here 
is some info that I thought may help you from 'dmesg':

The PCI BIOS has not enabled the device at 0/120 updating PCI command 0001-
>0005.
tulip.c:v0.91g-ppc 7/16/99
etho: Lite-On 82c168 PNIC rev 32 at 5x5800, 00:A0:cc:5c:0c:DD, IRQ 0.
etho: MII transceiver #1 config 3000 status 7829 adversting 01e1.
PCI latency timer (CFLT) is unreasonably low it 0.   Settings to 64. clock.


Thanks!
Comment 18 Bill Nottingham 2000-11-28 00:51:03 EST
Odd. I have the exact same Lite-On card, and I don't see any problems.

You may want to check your /etc/sysconfig/network-scripts/ifcfg-eth0;
above you have:

appaddr="192.168.1.101"

it needs to be

ipaddr="192.168.1.101"
Comment 19 Bill Nottingham 2001-02-01 17:11:36 EST
closing; that card works OK in testing here.

Note You need to log in before you can comment on or make changes to this bug.