Bug 1827883 - thermald-2.2 is available
Summary: thermald-2.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: thermald
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Berg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-25 05:38 UTC by Upstream Release Monitoring
Modified: 2020-07-02 01:11 UTC (History)
4 users (show)

Fixed In Version: thermald-2.2-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-02 01:11:28 UTC
Type: ---


Attachments (Terms of Use)
[patch] Update to 2.2 (#1827883) (909 bytes, patch)
2020-06-05 23:22 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2020-04-25 05:38:27 UTC
Latest upstream release: 2.1
Current version/release in rawhide: 1.9.1-2.fc32
URL: https://github.com/intel/thermal_daemon

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/14500/

Comment 1 Upstream Release Monitoring 2020-04-25 05:38:32 UTC
An unexpected error occurred while creating the scratch build and has been automatically reported. Sorry!

Comment 2 James 2020-05-31 13:05:45 UTC
Quick ping on this -- I'm using a local build of 2.1 from the upstream git, seems fine. Had to adjust the spec a bit and the monitor app's dependency had to be broken, but it works fine.

Comment 3 Benjamin Berg 2020-06-02 12:37:45 UTC
James, anything specific you did?

For a local mock build I just needed to add a BuildRequires on autoconf-archive. So I am wondering what you had to change for the monitoring application.

Comment 4 James 2020-06-02 12:51:03 UTC
I should clarify: this is with respect to the spec in the source under distribution_integration. To get this to work I simply ignored that the monitor package has an = version test rather than >=. I didn't test it thoroughly with mismatched versions, but the basic plot functionality worked.

When I got the spec from the Fedora SRPM (which is how I'm making it locally now), I just had to modify the version and place the source from Github in thermal_daemon-2.1.tar.gz. Then it built the daemon and UI packages fine with rpmbuild -bb. 

Note that I've since discovered thermald 2.1 causes regressions for me on one machine, at least with the config I've been using so far ( https://github.com/intel/thermal_daemon/issues/233 ), so right now I'm not rushing to update ;)

Comment 5 Upstream Release Monitoring 2020-06-05 23:22:34 UTC
Latest upstream release: 2.2
Current version/release in rawhide: 1.9.1-2.fc32
URL: https://github.com/intel/thermal_daemon

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/14500/

Comment 6 Upstream Release Monitoring 2020-06-05 23:22:39 UTC
Created attachment 1695542 [details]
[patch] Update to 2.2 (#1827883)

Comment 7 Upstream Release Monitoring 2020-06-05 23:25:14 UTC
the-new-hotness/release-monitoring.org's scratch build of thermald-2.2-1.fc30.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=45468923

Comment 8 Fedora Update System 2020-06-23 16:16:13 UTC
FEDORA-2020-51f37412c7 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-51f37412c7

Comment 9 Fedora Update System 2020-06-24 01:01:51 UTC
FEDORA-2020-51f37412c7 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-51f37412c7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-51f37412c7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-07-02 01:11:28 UTC
FEDORA-2020-51f37412c7 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.