Bug 1827906 - Index images are very large when built with opm
Summary: Index images are very large when built with opm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 4.5.0
Assignee: Evan Cordell
QA Contact: kuiwang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-25 11:12 UTC by Evan Cordell
Modified: 2020-07-13 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-registry pull 299 0 None open Bug 1827906: (fix) Use opm builder image for opm indexes 2020-06-23 10:24:04 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:47 UTC

Description Evan Cordell 2020-04-25 11:12:47 UTC
Description of problem:
An index image is very large when built with opm

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build an index image with `opm index add`


Actual results:
Image is 1gig+


Expected results:
Image should be ~50mb (binaries) + content


Additional info:

Comment 4 errata-xmlrpc 2020-07-13 17:31:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.