Bug 1827980 - 'hidden' descriptor should hidden property completely on the the creation form
Summary: 'hidden' descriptor should hidden property completely on the the creation form
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-26 06:23 UTC by shahan
Modified: 2020-07-13 17:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Manifested, discovered, and fixed before release.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5324 0 None closed Bug 1827980: Fix hidden descriptor 2020-10-20 18:55:52 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:47 UTC

Description shahan 2020-04-26 06:23:34 UTC
Description of problem:
'hidden' descriptor should hidden property completely on the the creation form

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-25-170442

How reproducible:
Always

Steps to Reproduce:
1. install logging operators, goto csv yaml editor
2. update visualization.kibana.replicas descriptor to hidden:
          - description: The desired number of Kibana Pods for the Visualization component
            displayName: Kibana Size
            path: visualization.kibana.replicas
            x-descriptors:
              - 'urn:alm:descriptor:com.tectonic.ui:hidden'
3. goto ClusterLogging operand creation form,  expand Visualization->Kibana 

Actual results:
3. only the pod-count spinner was hidden, the property "Replicas" still show there

Expected results:
3. The the property "Replicas"  should hidden as well
Additional info:

Comment 3 shahan 2020-05-09 03:42:06 UTC
The the property "Replicas" would be hidden。
4.5.0-0.nightly-2020-05-08-200452

Comment 4 errata-xmlrpc 2020-07-13 17:31:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.