Bug 1828106 - MCO is looking for a cloud configmap on baremetal when one is not created
Summary: MCO is looking for a cloud configmap on baremetal when one is not created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Stephen Benjamin
QA Contact: Polina Rabinovich
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 00:30 UTC by Stephen Benjamin
Modified: 2020-07-13 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
kube-cloud-config not listed (101.77 KB, image/png)
2020-05-26 11:29 UTC, Polina Rabinovich
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1685 0 None closed Bug 1828106: cloudConfig: remove bare metal from platforms that require a cloud conifg 2021-02-15 05:19:18 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:56 UTC

Description Stephen Benjamin 2020-04-27 00:30:27 UTC
Description of problem:

BZ#1825948 assumed baremetal used cloud.conf, and it does not. CI is currently failing with:

```
level=error msg="Cluster operator machine-config Degraded is True with
RenderConfigFailed: Unable to apply 0.0.1-2020-04-26-200215:
openshift-config-managed/kube-cloud-config configmap is required on
platform BareMetal but not found: configmap \"kube-cloud-config\" not
found"
```


Version-Release number of selected component (if applicable):
Lastest CI

How reproducible:
Always

Steps to Reproduce:
1. Install e2e-metal-ipi

Actual results:
Fails with above error

Expected results:
Success


Additional info:

Comment 6 Polina Rabinovich 2020-05-26 11:29:30 UTC
Created attachment 1692239 [details]
kube-cloud-config not listed

Comment 7 errata-xmlrpc 2020-07-13 17:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.