Bug 1828128 - Error occurs when adding access in Project Access page
Summary: Error occurs when adding access in Project Access page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Debsmita Santra
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 06:07 UTC by Debsmita Santra
Modified: 2020-07-13 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Edit role can be given to user (120.99 KB, image/png)
2020-04-28 12:15 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5183 0 None closed Bug 1828128: Fix issue with adding access in the Project Acess Page 2020-06-24 01:21:52 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:31:56 UTC

Description Debsmita Santra 2020-04-27 06:07:32 UTC
Description of problem:
In the project Access page, when trying to add Access it's throwing an error saying `rolebindings.rbac.authorization.k8s.io "cluster-samples-operator-openshift-<role>" not found`.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. Go to Project in the Developer Perspective
2. Click on the `Project Access` tab
3. Click on `Add Access` & try creating a role binding by adding user name and role

Actual results:
Error occurs saying `rolebindings.rbac.authorization.k8s.io "cluster-samples-operator-openshift-<role>" not found`.

Expected results:
Access should be added successfully

Additional info:

Comment 3 Gajanan More 2020-04-28 12:15:37 UTC
Created attachment 1682452 [details]
Edit role can be given to user

Comment 4 Gajanan More 2020-04-28 12:16:11 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.ci-2020-04-27-195432
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot.
Marking this bugzilla as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.