Bug 1828167 - python2-click got removed without notice from Fedora 31 and 30
Summary: python2-click got removed without notice from Fedora 31 and 30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-click
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 08:07 UTC by Miro Hrončok
Modified: 2020-05-13 03:36 UTC (History)
5 users (show)

Fixed In Version: python-click-7.1.1-1.fc31.1 python-click-7.1.1-1.fc30.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-07 04:20:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-04-27 08:07:13 UTC
Description of problem:
The python2-click package got removed without notice from Fedora 31 and 30.

https://bodhi.fedoraproject.org/updates/FEDORA-2020-c52f4e231b
https://bodhi.fedoraproject.org/updates/FEDORA-2020-f19d1cb033

Version-Release number of selected component (if applicable):
python-click-7.1.1-1.fc31
python-click-7.1.1-1.fc30

Steps to Reproduce:
1. dnf install python2-click

Actual results:
No package found for: python2-click

Expected results:
Packages are not removed from already released Fedoras.

Additional info:
This happened because a blind merge with master happened. Please, don't do that.




$ repoquery --releasever=31 --repo={fedora,updates{,-testing}} --latest=1 --whatrequires python2-click
python2-flask-1:1.0.2-6.fc31.noarch

https://koschei.fedoraproject.org/package/python-flask?collection=f31



$ repoquery --releasever=30 --repo={fedora,updates{,-testing}} --latest=1 --whatrequires python2-click
flr-0:0.0.4-7.fc30.noarch
python2-fedmsg-0:1.1.1-4.fc30.noarch
python2-flask-1:1.0.2-4.fc30.noarch
python2-sphinx-intl-0:0.9.11-5.fc30.noarch
regindexer-0:0.6.2-1.fc30.noarch

Comment 1 Fedora Update System 2020-04-28 16:35:14 UTC
FEDORA-2020-b3a0b94818 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b3a0b94818

Comment 2 Miro Hrončok 2020-04-28 22:51:58 UTC
Note: Fedora 30 is still broken.

Comment 3 Fedora Update System 2020-04-29 01:55:47 UTC
FEDORA-2020-b3a0b94818 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b3a0b94818`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b3a0b94818

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Miro Hrončok 2020-05-04 22:47:05 UTC
Fedora 30 is still broken.

Comment 5 Fedora Update System 2020-05-04 22:57:12 UTC
FEDORA-2020-378e2a64cd has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-378e2a64cd

Comment 6 Fedora Update System 2020-05-05 06:07:49 UTC
FEDORA-2020-378e2a64cd has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-378e2a64cd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-378e2a64cd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-05-07 04:20:34 UTC
FEDORA-2020-b3a0b94818 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-05-13 03:36:29 UTC
FEDORA-2020-378e2a64cd has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.