Bug 1828238 - [OCP4.2 on OSP][IPI] does not deploy bootstrap node using volume boot
Summary: [OCP4.2 on OSP][IPI] does not deploy bootstrap node using volume boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On: 1820434
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 11:42 UTC by Pierre Prinetti
Modified: 2020-07-31 11:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some OpenStack environments might enforce a policy where VMs can't boot with ephemeral disks and need to boot from a cinder volume. Consequence: In these cases, it is impossible to install OCP with IPI because even when configuring the master and worker nodes to boot from volume using the rootVolume setting, the bootstrap node would still boot from ephemeral disk. Fix: Have the bootstrap node follow the rootVolume settings from controlPlane machine pool. Result: It is now possible to install OCP in OpenStack environment that enforce a policy where VMs can't boot with ephemeral disks.
Clone Of: 1820434
Environment:
Last Closed: 2020-05-18 13:35:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3511 None closed Bug 1828238: OpenStack: Allow Booting bootstrap node from volume 2020-07-31 08:04:06 UTC
Red Hat Product Errata RHBA-2020:2133 None None None 2020-05-18 13:35:23 UTC

Description Pierre Prinetti 2020-04-27 11:42:25 UTC
+++ This bug was initially created as a clone of Bug #1820434 +++

Description of problem:

  OCP4.2 IPI on RHOSP does not deploy bootstrap node using volume boot.

  In some actual RHOSP13 environments, only the volume boot is available.
  So, the use of image boot is restricted, because
     - RHOSP operation becomes simple or easy at the migration and system trouble.
     - some end user customers do not recognize the difference between image boot and volume boot

  In this case, "openshift-install create cluster" by OCP4.2 IPI on RHOSP fails.

Version-Release number of the following components:

  RHOCP 4.2

How reproducible:

  $ openshift-install create cluster

  Note: The OSP environment has a limitation, so only the volume boot is available.
     
Steps to Reproduce:
1. openshift-install create cluster
2.
3.

Actual results:

  "openshift-install create cluster" failed.
     
Expected results:

  "openshift-install create cluster" succeed.

Comment 5 errata-xmlrpc 2020-05-18 13:35:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2133


Note You need to log in before you can comment on or make changes to this bug.